Jump to content

MvdM

Moderators
  • Content Count

    108
  • Joined

  • Last visited

  • Days Won

    2

MvdM last won the day on April 8 2019

MvdM had the most liked content!

1 Follower

About MvdM

  • Rank
    Expert User

Profile Information

  • Gender
    Not Telling
  • Are you University user?
    No

Recent Profile Visitors

2036 profile views
  1. MvdM

    Warning 38142

    Hello @fudy Look for the warning in the .out file. Just above the warning, the frequency range for the selected predefined coaxial cable should be displayed. As I understand it, the warning tells you that the simulation frequency is outside the frequency range where the predefined coaxial cable is defined and the cable parameters as defined at the closest frequency to the simulation frequency is used.
  2. You are not setting the custom mesh properties correctly. Use macro recording to see the scripting equivalent of the custom mesh settings you would like to define.
  3. The variables in the PRE file are defined before the IN card. The IN card is set to include variable definitions from the .cfm file. The values are the same because the variables are all set to 1 in the CADFEKO model.
  4. Maybe the code explains it better. mesh_cubes_local.luamesh_cubes_selectively.lua It might not do exactly what you want, but it should illustrate the concept.
  5. Yes, the setting can be applied using a Lua script. If you are not familiar with the API, please refer to the Example Guide for the Introduction to Application Automation. You can also use macro recording in CADFEKO to record the scripting equivalent of performing steps in the user interface - look for "Macro Recording" in the User Guide. For the option shown above, refer to the CADFEKO API documentation. Go to the Face object. It has the properties LocalMeshSize and LocalMeshSizeEnabled. An alternative could be meshing the cubes one-by-one, which is what you initially set out to do. But then you have to change the mesh size for each cube if you want the cubes to have different mesh sizes! Either set local mesh sizes and mesh the whole model once (using Mesh), or mesh the cubes one-by-one (with MeshSelective) using different mesh sizes for each meshing operation. In the script you attached above, you are using a custom mesh size of 0.2 (and in the other comment two values: 0.01 and 0.2). It would be fairly easy to vary the mesh size based on the cube length with something like: mesh_size = tostring(Length_list[cube_index]/2) Note: You did not iterate over the cubes in the attached script, so maybe follow the option of setting a local mesh size for each cube and meshing the model once.
  6. If you prefer using a for loop like shown above to loop over geometry parts (instead of setting local mesh sizes), you can use MeshSelective: project.Mesher:MeshSelective({temp_cube},{})
  7. MvdM

    Meshing Error

    Hello @pmcardle There seems to be a problem with the geometry of Face383 that causes problems for the geometry modeller, leading to problems during meshing. By splitting off the top part of Face383, you can see where it struggles to recover the correct/expected definition: Meshing succeeds for the rest of the model (as can be seen by cutting out that part): Short from rebuilding the face, I don't know what would help. Maybe others have some suggestions for you. Kind regards Madelé
  8. Hi @SanderBash Geometry like spirals and helices seem to provide a challenge for the algorithm used by the meshing library. Splitting the structure simplifies it just enough for the algorithm to work. Improvements have been made in previous versions of CADFEKO (including 2018.1 and 2019.2) and will be made again. The "normal" way of meshing should work and the developers will have to look at what's going wrong.
  9. MvdM

    Error 3978

    Hello @preaulpi Please attach your model files, or contact Support for assistance, see https://altairhyperworks.com/ClientCenterHWSupportProduct.aspx. You can submit a support ticket on Altair Connect. Kind regards Madelé
  10. Regarding the original error reported in this thread, this error can be triggered in POSTFEKO if the result cannot be plotted on the 3D view. For example, in your model @ebdaculan, the far field cannot be plotted on the 3D view because it contains a single point only. If you increase the number of points in the far field request, the far field pattern can be plotted. Did you get this error when plotting currents? I have not managed to reproduce the error when plotting the currents for your model.
  11. I'm glad that Support could help you to solve the issue! Just noting here that the update containing the fix (2019.3.1) is now available.
  12. Hi @Hans kalaran This problem will be resolved in the next Feko update (2019.3.1) that is scheduled to be released soon. Kind regards Madelé
  13. Hi @Ab28 The Gerber export for the attached model works in the latest version, CADFEKO 2019.3. The problem that you see was resolved in CADFEKO 2018.1. A workaround that you can use to get your export to work correctly in CADFEKO version 7, is to draw the geometry in such a way that there are edges that connect the outer edge of the face to the edge of the hole, for example like this: This creates individual faces where each face is completely filled in (with no holes). A model like this should export correctly, even in the much older version of CADFEKO. For comparison, you were exporting the faces with the holes encapsulated in a single face: Kind regards Madelé
  14. Hello @Ranjitha Ravishankar If you attach your model file (.cfx) others could take a look at the definition of the anisotropic material in your model. From the CEM validate output, it still looks like the anisotropic material definition is not valid.
  15. Hello @Ranjitha Ravishankar Feko only supports passive media, so you should review the anisotropic medium definition. Is the defined medium a passive medium? You can run CEM validate (Solve/Run tab) in CADFEKO to see which regions (and media definitions) trigger errors. If you need further help, please add your .cfx model and/or .out file. Also, what version of Feko are you using? Kind regards Madelé
×
×
  • Create New...