Jump to content

Rango

Members
  • Content Count

    1
  • Joined

  • Last visited

About Rango

  • Rank
    Newbie

Profile Information

  • Gender
    Not Telling
  • Are you University user?
    No
  1. Hello, I’m currently trying to do a contact analysis of a shaft-hub joint-connection in RADIOSS. The model: Both parts are initially in closed contact with each other in a press-fit joint-connection. The shaft is rotating around its axis with very high velocities and eventually the cylindrical hub detaches from the shaft when a critical rotational velocity is reached or due to fatigue. I would like to simulate that detachment process in RADIOSS and have now come across several problems I can’t find a solution to. ------ Here is what I do: 1. After meshing the geometries with solid elements I create a rigid body at one end of the shaft to apply CLOADS or rotational forces to it. 2. I create a contact surface on the outer surface of the hub and apply a PLOAD all around it to simulate the press-fit connection between the hub and the shaft. 3. Properties and materials are defined for both the rigid and solid elements. 4. I create a Contact between hub and shaft and select the shaft-component as the slave and the hub-component as the master. 5. A local coordinate system is placed at the center of the shaft to define the axis of rotation. 6. Next, a rotation should be added to the system, however, that’s when the problems start. - When I try to apply an “initial velocity around an axis” load collector around the shaft axis(local system) I get the error that the wrong reference frame was selected. However, when I select the global system, the error “Direction should be x y or z & right justified” is detected. - When I use an imposed velocity/acceleration, I simply get zero displacements everywhere as if the load collector was not created at all. These errors occur no matter whether the velocity is applied to the rigid or the shaft component itself and with or without a PLOAD collector active or not. -When I applied CLOADs on two sides of the rigid body, thus creating torque, it didn’t work in combination with the applied PLOAD. In another forum entry it was explained that a simultaneous application of multiple loads like that is not possible. Instead they should be applied one after another and in the end the combined effects could be evaluated. However, the results do not show a combined load case like intended. Additionally, the rotation does not continue in one direction only, but bounces back and forth after a while when CLOADS create the torque. ----------------------------------- ----------------------------------- My first question would be whether my intended goal – observing the contact/detachment process between hub and shaft at a critical rotational velocity- is possible to implement in RADIOSS like that or what I would need to adjust to make it work. 2. How can I apply a rotational velocity to the shaft in order to rotate the component in one direction only? 3. Since the hub is supposed to be rotating with the shaft before detaching, what contact is needed to simulate that detachment behavior? I would be happy to send the files to make it easier to understand the model and output since this explanation probably isn’t enough to give a clear answer to all of my problems. Thank you in advance for the support!
×
×
  • Create New...