Jump to content

Alejandro Rodríguez

Moderators
  • Content Count

    85
  • Joined

  • Last visited

  • Days Won

    3

Alejandro Rodríguez last won the day on November 27 2019

Alejandro Rodríguez had the most liked content!

3 Followers

About Alejandro Rodríguez

  • Rank
    Advanced User

Profile Information

  • Country
    France
  • Are you University user?
    No

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hi, Sorry for my late answer. Please, find below the answer to your questions. · To define the magnet orientation along z axis, stablish the orientation variables as shown in the image. In fact, it is a matter to choose the proper coordinate system and angle. You can also represent your Br orientation before resolution through the menu Physics -> Display arrows on magnet. · This type of collision should not be possible. If I have understood correctly, your magnets are moving inside the air region (in yellow). Your magnets must remain inside this region at any time, this will automatically avoid collision with the external (fixed) magnets. Please, check your mechanical set options and the time instant you are simulating in your scenario and make sure your air region is compressible and not part of the moving mechanical set. · Sorry for the low quality of my image in the previous post. You are right, the best way to represent the torque of the moving part is the formula TorqueElecMag(MOBILE). Best regards, Alejandro
  2. Hello, You are welcome. I advise you to check your magnets orientation, you have defined their Br following x axis but, seeing your geometry, it seems more likely to me that Br orientation follows z axis. You can update the orientation through the menu physics -> Material -> Orient material for volume region. Regarding magnetic torque, the best way to obtain it is to represents the global torque of the mechanical set: Curve-> 2D curve (I/O parameter)-> new 2D curve and then to define the formula select the mechanical set option (see the image attached). Hope this helps. Best regards. Alejandro
  3. You are welcome. Do not worry. We are here to help. Have a nice day.
  4. Hi Andoni, Probably this problem arises because you have generated different solid bodies in the same physical space. You need to combine all these objects. In the modeler, there are several possibilities to do so, depending if you want to merge all the bodies in the same volume or to create different volumes. In order to combine all bodies in the same entity you should carry out an union (see image below, the icon in the left, with an u), or an assembly to divide the bodies into different volumes without collisions between them (icon in the right, with an a). Hope this helps. Best regards. Alejandro
  5. Hello, The problem here is in the mechanical set definition, I guess you have defined your magnets in yellow as a rotating mechanical set and magnets in purple as fixed and you do not have defined the yellow box of air as compressible. In order to solve your project, you need to define a mechanical set compressible and assign it to the yellow box of air. This is the way to that the yellow air area must be remeshed each time step, otherwise Flux will not be able to consider the movement. Hope this helps. Best regards. P.S: The method shown in the tutorial does not work in your case because, in the tutorial, there exists a sliding surface (i.e., the border between moving and fixed part is a well-defined revolution surface. That quality makes the remeshing unnecesary), which is not your case.
  6. Hi Aravind, When you create your connector, you should decide which parameters will be fed from Simulink, then you can connect Simulink sources to them. You do not need to use voltage source directly in Simulink, rather you should define another input in Simulink (sine wave or any other) and them assign the parameter it is piloting as temporal value of your current source. Nearly everything is parametrizable in Flux: you can parametrize your voltage source value inside Flux and the resistance of your circuit component, including solid conductors. To simulate your device, you should define the blue and red volumes as solid conductors and then generate a circuit to link them to a circuit. Finally, you can choose which faces are the input and outputs of your solid conductor. Hope this helps. Best regards,
  7. Dear Andoni, About the difference between active power and Joule losses I think you will find an explanation in Flux help, more precisely: C:/ProgramFiles/Altair/2019/flux/Flux/Help/Flux/english/Website/index.html?InterpretationDesResultatsPuissancesEtPertes.htm where C:/ProgramFiles/Altair/2019/ should be replaced by your Flux installation directory. Hope this helps. Best regards, Alejandro
  8. Hi Aravind, You are welcome. I have not a clue about why your simulink is not able to read your F2MS file, since now your Flux and your Simulink versions are compatible. Please, try to generate a new file with another name just to be sure this is not a path problem. Best regards, Alejandro
  9. Hello Balaji, In fact, if your values are changing when you change the infinity box size, that means that it is to small for your problem. It can be a meshing problem but, most probably, the reason is that your physics is not well represented with such small infinity box. As Andoni says, the infinity box limits should be “long enough” your device. In other words, flux should be quite low when reaching the infinity box boundary, otherwise it is too small. Given fixed rules to decide when a box is “big enough” is not a simple task, and there are not infallible rules, since it depends on device geometry and physics. For example, if you are representing a motor surrounded by a ferromagnetic stator, most of the flux will be confined inside the machine, with very low leakage flux going to the air, in this case you can define a small infinity box. On the contrary, if the device is on air with no ferromagnetic material limiting it, box sized required will be higher. As a rule of the thumb, we advise to establish the internal size of the infinity box between 1.2 and 2 times the device radius. Best regards, Alejandro
  10. Dear Mostafa, There are two things that are worthwhile to notice for LS model users. Firstly, that this is a mathematical model, made to fit with real measures. That means that the concerning of the model is to get a good global value, while values for each instant are less significant, that is why usually waveform are not very relevant. Secondly, iron losses are positive because the realignment of the magnetic domains takes energy to be done, but a small fraction of this power can be given back when these domains goes through a lower energy configuration. Therefore, for some given instants, losses can appear as negative, though globally it will always be positive. Best regards, Alejandro
  11. Hello Aravind, I think the problem is that you have indicated as directory C:\Program Files\MATLAB\R2018a\bin, it should be C:\Program Files\MATLAB\R2018a, instead. Try this, I think it is going to work. Best regards, Alejandro
  12. Dear Aravind, Your settings are right, electric applications have less option than magnetic ones. Best regards,
  13. Hi Mostafa, Unfortunately, I think you are right, this problem is probably related with Matlab version compatibility. For the moment, Matlab R2019a is not qualified for coupling with Flux. Please, see the table below to check versions compatibility. Best regards,
  14. Hello Aravind. I think problem there is that you are not in the right application. The options that appear in the solving tag depends on the application you have previously defined. Matlab coupling is working for transient magnetic and transient thermal applications, if you have defined your application as steady state AC or static, Matlab coupling will not be available. Best regards,
  15. Hello Amina, It seems that Simulink is not able to find Flux. To properly run this coupling there are some actions you should do: · You should launch a file to activate the API. The default path to this file is: C:\Program Files\Altair\2019\flux\Flux\Bin\prg\win64\Active_Distributed_Computation_and_API. Please, run this file with administrator rights. · After this, open Matlab/Simulink from Flux Supervisor. Go to Supervisor Options -> Access paths -> Coupled software. There you should put your Matlab directory path. Then open Matlab using the button with an arrow (see image). Please, try this. If your error persists, I will need additional information to solve it. Best regards,
×
×
  • Create New...