Jump to content

denizbilgili

Members
  • Content Count

    32
  • Joined

  • Last visited

Everything posted by denizbilgili

  1. Thanks Prakash. Sorry, I thought the case was forgotten. I have checked the .fem and .mnf you shared. In MODEL, Elset is set to ALL but the docs say for CMS SE generation it is defaulted to NONE. But mnf OUTPUT captures no modes in the mnf file when it is set to NONE so I think we'll have to wait for the devs to share what they find. I'll be waiting for your response. Thank you for your time.
  2. Hello, I would like to remind that I am still looking for a way of generating superelements with Craig-Bampton Method in Optistruct for Adams (MNF file format). I would like to know if there is a way around. So far, I have tried a few ways combining PLOTEL, NORIGID and NONE in the MODEL card but still no luck. Thank you.
  3. Hello Prakash, I have set V1 = 0 and requested 10 modes. .out file now gives the total mass (3.14e-5) as you have also obtained in your results. Though, there are small differences in individual modal masses between your and my results, but I don't think that's an issue. Thank you very much for your help.
  4. Hello Prakash, I have tried as you said, the problem still exists. On the machine with 2017 build, there are no problems, everything works both with DISPLACEMENT and ACCELERATION. However in 2017.2, I am unable to select response node sets for DISPLACEMENT and ACCELERATION entries. I have tried two machines with 2017.2 build installed, the problem was seen on both machines. Thank you.
  5. Hello Prakash, Thank you for your response. I have a node set for response calculation and I am able to select this node set for the SID entry in DISPLACEMENT. However, I am unable to select this same node set for the SID entry in ACCELERATION. When I enable ACCELERATION and click on Option -> SID, the window that pops up showing available node sets for selection is empty. So it doesn't let me select that node set for ACCELERATION. I'm outputting using HGFREQ and I am able to solve the model and plot the results in HyperGraph if I use DISPLACEMENT. However, since it doesn't let me select the same response node set in ACCELERATION, I'm unable to run an analysis using ACCELERATION. Thank you. Update: I have just noticed that I can't select any node sets in DISPLACEMENT too. This is happening in version 2017.2. Yesterday I was able to select node sets in version 2017. I will check back with my 2017 build as well as on different machines with 2017.2 build and update my answer.
  6. Hello, I am using Optistruct to numerically calculate some FRFs. I have test data to validate my numerical results. Measured test data is an FRF data in the form of Inertance (acceleration/force). I see that there is a big gap in frequency components' amplitudes between the measured data and numerically calculated data, though calculated and measured natural frequencies align very well. I have followed the modal frequency response tutorial and nowhere in the tutorial is it shown that we're specifically selecting the type of FRF we're wanting (e.g. inertance or mobility or receptance). GLOBAL_OUTPUT_REQUEST is used with DISPLACEMENT enabled and that makes me think that, what I am calculating in Optistruct is Receptance and not Inertance. I tried to request ACCELERATION instead of DISPLACEMENT, but ACCELERATION doesn't let me select the output node set which I used for DISPLACEMENT. How can I make sure in Optistruct that the numerical data I'm getting is inertance and not mobility (velocity/force) or receptance (displacement/force)? Best regards
  7. Hey Prakash, if you check the .mass file I shared in my previous posts, you'll see that the numbers don't add up to 3.14e-5 tons, which is the total mass of my test structure. In fact, the numbers are way higher than the total mass of my system. Attached is the .fem file for my test structure and modal analysis. I would be grateful if you could share more information with me on this. Thank you for your time. effmass.fem
  8. I would like to remind you my last inquiry. As I said, I am able to print the results to the HG file, however I am unable to interpret the results. My model uses metric tons for mass unit, how can I interpret the results and see if they add up to 90% of total mass or not? Thank you
  9. Thanks Prakash. As I said, I am able to output the results now. However they don't add up to the total mass of the system so I would you to share with me more information on the units used in the .mass file. Thank you I have added a screenshot of hypergraph plots. X and Y axes are not labeled so I'm unable to interpret the plot.
  10. Hello Prakash, I added the OUTPUT card with HGEFFMASS selected, however I don't see any option asking me where to write it. I checked the docs on HGEFFMASS and it says: and says *.mass and *_mass.mvw files are used to store modal effective masses. I do get these files so I used HyperGraph to plot the .mass file Optistruct generated. There is indeed some data in it but they aren't labeled properly so I don't know which data represents which property. I would like more help on this. Also, the entries in out file are the same as I posted above. ADDITION: I have seen the doc pages for .mass and _mass.mwv files. Attached is my .mass file. I have understand that the rows are for each requested mode and columns are for subcases. However, I don't know the unit of these values. The total mass of my test system is 3.14e-5 tonnes, or 31.4 grams. The magnitudes in the .mass file are very large compared to my total mass if .mass file gives modal effective masses in my units. Could you tell me what unit .mass file uses? Thank you effmass.mass
  11. Hello Prakash, I have tried both in 2017 and 2017.2. They're generating the same results in the .out file. Results from a sample for effmass is attached. It seems to be working but my problem is I can't see any entries for modal effective mass in this output. Thank you effmass.txt
  12. I have a relatively large flexbody model and I want to make sure that I include the absolute minimum number of flexible modes which will still be sufficient to model the system's dynamics. I want to use modal effective mass approach and include a number of modes such that those modes' total modal effective mass corresponds to about 90% of the system's total mass.
  13. I would like to remind you my inquiry. I didn't want to start a separate topic since this one is on the exact same subject. Thank you for your time.
  14. Hello Prakash, Attached is an example file modelled in the same way as I always generate flexbody models. Since I cannot share an original model file, attached model consists of a very simple geometry. Kind regards altair_cms_adamsmnf.fem
  15. I would like to know this as well. I am using PARAM, EFFMAS to calculate modal effective mass and I am getting similar results, but I don't know how to calculate the effective mass of each mode with given data in the out file. I would be happy to know how I can obtain modal effective masses using Optistruct.
  16. Hello Prakash, I have tried with the settings you gave me. When I use MODEL,NONE,NONE,NORIGID in the fem file, the generated mnf file raises below error in Adams. ERROR: Flexible body .MODEL_1.FLEX_BODY_1 requires one or more modes for constant, partial, or full inertia coupling. So it seems that when I use MODEL,NONE,NONE,NORIGID, no DOFs are exported at all. When I try the same with MODEL,NONE,NONE,RIGID I get the same results as before (namely, the full flexbody solution). My CB solution for the flexbody model has 10 modes plus 1 ASET, constrained in 6 DOFS. So I expect to have 16 DOFs in the full model. The MNF generated with MODEL,NONE,NONE,RIGID has 16 DOFs when I check it in Adams. I can verify this with the file sizes of generated mnfs too. MODEL,NONE,NONE,NORIGID generates an mnf of 5 kilobytes while MODEL,NONE,NONE,RIGID generates an mnf of 48 kilobytes. So MODEL,NONE,NONE,NORIGID one is nearly an empty file due to no DOFs being exported. I would appreciate further help with this issue. Kind regards
  17. Hello Prakash, Thank you for your response. Since my flexbody models are very large and simulation times are rather long, it is very crucial for me that I export only ASET DOFs to the MNF files; otherwise I won't be able to work with my model at all due to very long computation times. I hope there is either a direct solution or an equivalent workaround to achieve the same effect. Update: If there is a way of achieving this by using another profile in hypermesh, say, Nastran, then I'd like to know that as well since I can try to use another profile and thus another solver than Optistruct. Best regards
  18. Dear Support Team, I use Hypermesh and Optistruct to build flexbody models to use in MSC Adams MBD models. Since my flexbody models are large and have too many unused DOFs, I need to reduce them only to ASET DOFs. In the particular problem I'm trying to solve, I have a machine part with a few ASETs to attach/constrain it and a single location where I get response data from. So, the only DOFs I need are the DOFs of this response location (in addition to the DOFs of other ASETs). I can put an ASET on this location but I don't know how to force Optistruct to output only ASET DOFs to the generated Adams MNF file. In the docs for Optistruct MODEL solver card, Comment #1 states that: "For CMS superelements output in h3d format, only the ASET DOF are output when the MODEL data is not present." I need this same effect but with MNF format and not h3d format, since I work with MSC Adams and not Motion View. I have tried a few ways on my own but have been unable to succeed. Any help would be greatly appreciated. Best regards.
  19. Hello Prakash, Thank you for your answer. Though I understand that CMBEAM is specifically designed for MBD analyses, I would like to know some more, even at an abstract level, about the differences between the two. I do not necessarily ask about the mathematical formulation differences between the two, but I'd like to know more about the conceptual differences which would give me a general idea about what they really are. For example, since it is possible to use both CBEAM and CMBEAM for an MBD analysis, what would really differ between two analyses one of which uses CBEAM and the other uses CMBEAM? That is, of course, if it's possible for you to share with me. Thank you for your time. Kind regards
  20. Dear all, I am building an elastic multi-body dynamic model and I need to model the screws connecting some parts in the model. I plan to model the screws as 1D beam elements. I have seen that I have two options, CBEAM and CMBEAM. The documentation says: CBEAM: The CBEAM bulk data entry defines a beam element (BEAM) of the structural model. CMBEAM: Defines a beam element for multi-body dynamics solution sequence without reference to a property entry. I'm leaning towards CMBEAM more as it specifically states the element is for multi-body dynamics. But I don't quite understand the differences between the two. I have seen CMS models which use CBEAM instead of CMBEAM so it seems it is indeed possible to use CBEAM in an elastic MBD analysis. I would be grateful for any further information regarding the differences between CBEAM and CMBEAM, as well as which one should be used for an MBD analysis comprising flexbodies. Best regards, Deniz Bilgili
  21. Hello Prakash, Thank you for your response, and apologies for my late response, I have been out of work for some time. When I use the Analysis -> Interfaces -> Add panel, I am able to select a SET_GRID for SID1 and MBDSRF for SRFID as you said. However, when I use the Analysis -> Interfaces -> Create panel to create an interface and then use the tree item to assign entity sets to SID1 and MBDSRF, the problem I mentioned in my first post occurs. Please see below images. Figure 1 Figure 2 Another point is, when I use the Analysis -> Interfaces -> Add panel, it does let me select a SET_GRID for SID1; however, even though the tree item says 1 set is assigned to SID1, when I press on the sets button as shown above in Figure 1 to view the assigned set, it again gives me a blank screen just like it shows in Figure 1. Could this be a possible bug? I haven't tried to run an analysis so I do not know yet whether it will be able to use the assigned sets or not. Thank you for your time, Best regards
  22. Dear all, I am trying to define a multi-body deformable surface contact for Optistruct using MBDCNTDS type of interface. Below image shows the doc page for this type of interface. As the docs say, I have made an MBDSRF type node set to use as the deformable surface. I am able to pass this MBDSRF type of set into the SRFID entry of the MBDCNTDS . So no issues with the deformable surface part. However, when I try to make a node set for the SID1 entry in MBDCNTDS, it will not accept any of my node sets which are saved as entity sets. I have tried using many different card images (SET_GRID and many other), still, the SID1 entry of the MBDCNTDS I'm setting up will not see my node set. I would be grateful if you could share any information with me regarding the type of node set I should use which can be passed into the SID1 entry of MBDCNTDS. Relevant info: I'm using Hyperworks 2017 Best regards, Deniz Bilgili
  23. Hello Prakash, Sorry for the late response. I'll need to speak with the IT department to see if they can update my Hyperworks softwares to version 2017.1. It is good news that it's possible to output MODALSE in 2017.1. I will check back in with you when I test it out myself. Thank you for your time and help, Best regards
  24. Hello Prakash, Yes, I am running frequency response analysis. As you can see in the first image I have provided in my first post, my subcase's analysis type is set to "Freq. resp. (modal)". Kind regards
×
×
  • Create New...