Jump to content

Search the Community

Showing results for tags 'optistruct'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Altair Support Forum
    • We will be migrating the Altair Forums on September 27th -  October 2nd to the Altair Community
    • Installation , Licensing and Altair One
    • Modeling & Visualisation
    • Solvers & Optimization
    • Multi Body Simulation
    • Conceptual design and Industrial design
    • Model-Based Development
    • Manufacturing Simulation
    • CAE Process Automation
  • Academic Partner Alliance Forum
    • APA - Composites
    • APA - CFD & Thermal
    • APA - Vehicle Dynamics
    • APA - Manufacturing
    • APA - Crash and Safety
    • APA - Noise, Vibration and Harshness
    • APA - System Level Design
    • APA - Structural and Fatigue
    • APA - Marine
    • APA - Optical Design
  • Japanユーザーフォーラム
    • ユーザーフォーラムへようこそ
    • Altair製品の意外な活用例
    • インストール / ライセンス / Altair One / その他
    • モデリング(プリプロセッシング)
    • シミュレーション技術(ソルバー)
    • データ可視化(ポストプロセッシング)
    • モデルベース開発
    • コンセプト設計と工業デザイン
    • 製造シミュレーション
    • CAE プロセスの自動化
    • エンタープライズソリューション
    • データアナリティクス
    • 学生向け無償版(Altair Student Edition)

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Interests


Organization

Found 675 results

  1. Quick question everyone... Is it possible to extract contact forces in such a way that they can be imported into another model as a pressure? The model I have has wearpads with contact OPTI - so I get a text file with a force result for that contact, but when you open the result in Hyperview, you can clearly see how the force varies over the surface.. and that's what I need to simplify my model. Does anyone know how to extract that result? The image below is reported as a net of 13.4kN in the opti file yet clearly the majority is in the corner.
  2. Hello, I am trying to perform a simple lattice optimization using optistruct in order to create a tensile specimen with lattice structure. When I run my optimization, a feasible design is found however the resulting .fem file no longer has a solid for the non design space. This becomes apparent when I try to export the results to .iges I've attached the relevant files as reference: ASTM_D638_02a_TypeIII_lattice.fem ASTM_D638_02a_TypeIII.hm Thanks Malcolm
  3. Hello, I run OptiStruct but got empty results. My operating system: Win10 + Hyperworks Student Version I followed this tutorial deleted all the files but it still doesn't work... Thank you! Zizhe
  4. Hi All, I have a question involving the HyperMesh preprocessor. I'm trying to run a transient thermal analysis, where there is a consistent base boundary condition, and convection is applied, but only after a delay. I'm having a hard time figuring out how to apply convection partway through the analysis. For example, I'm allowing the part to heat for 25 seconds, and then turning a fan on and blowing on it for the last 25. I have my TLOAD1, TABLED1, SPCD, and SPC collectors for convection, but I can't figure out how to apply this delay. I tried setting the TABLED1 value to 0 for the first 25 seconds, but that just sets temperature to zero I believe. I imagine the DELAY_OPTION would be helpful, but I don't know how. Thanks very much for any help you can provide.
  5. Hello, I am attempting to run an optimization using Optistruct but the solver keeps outputting the following error: *** ERROR # 312 *** In static load case 1 the compliance is negative or large 1.7638e+015. Optimization/buckling analysis cannot be performed. due to possible rigid body mode. INFEASIBLE DESIGN (AT LEAST ONE CONSTRAINT VIOLATED). From what I understand, this error could be from a model that is not fully constrained or from poorly defined materials properties. My model is constrained with 2 RBE3 elements so I believe my constraints are not the issue and I don't understand what could be wrong with my material inputs. I have attached my model for reference. Any help would be appreciated Thanks ComparisonStudyModel.hm
  6. A fatal error has been detected during input processing: *** ERROR # 3405 *** Internal overflow happened due to the large size of model. This version of OptiStruct can not solve it. Could somebody help me to solve this problem
  7. Hello, I am receiving this following error message: ERROR # 605 Element 917177 is referenced by STACK 1 (on PLY 2) and by STACK 2 (on PLY 12) simultaneously. I looked at previous topics about this error message and checked the stacks to make sure the same ply is not used in both stack 1 and 2. But I am still having difficulty in finding and changing the ply property of the element in the error message. Does anyone know how I should proceed to solve this error? Thank you Muge
  8. *** INTERNAL PROGRAMMING ERROR *** in file "dppdrv1.F", at location # 1034. **** ABORTING RUN DUE TO AN INTERNAL ERROR **** ************************************************************************ OptiStruct error termination report printed to file "opti.stat". Someone please tell me what is the problem opti.stat
  9. Hello every body . Do you have experience about seam welding for optistruct . I need some help for tutorial or example how to use seam welding function . Could you please help me ?
  10. Hello, I am trying to run a linear static analysis which has 36 loadsteps. I need to apply these loadsteps in sequence and need the results from the previous step to be retained for the next step. I am trying to use the statsub(preload) card but it gives an error that subcases cannot be nested. What is the right way to do this in a linear static analysis.
  11. bmech

    MFLUID

    Is there any tutorials or reference exercise in order to learn MFLUID in optistruct for modal analysis? Regards
  12. Hi all, Am trying to find a line of code which will select a component / assembly / set etc, when the name contains a certain string... for instance the assembly name may read "apples-001001a" but I want a script to select that assembly if the name contains "apples" as the number could change in the future. Any ideas? Cheers Andy
  13. I am looking to write a windows batch file or linux script that would generate an Optistruct .fem input file given an .hm file. I looked through the hwsolver/scripts available in Windows versions but it was not obvious as to what to do for this. Could some help or direction be provided on this? Thank you!
  14. Hello Everyone, I am trying to find the right commant to modify the analysis type of a loadstep by a small script. When I am looking for the cmd. file after doing this manually using the gui, I see the following command: *setvalue loadsteps id=1 STATUS=2 OS_TYPE=1 But nothing happens when I insert this command into my small code. No error message jumps up, but the setting of the analysis type will be not changed. In the small macro I created it looks like the following: *retainmarkselections 1 *renamecollector loadsteps "loadstep1" "temp" *retainmarkselections 0 *setvalue loadsteps id=1 STATUS=2 OS_TYPE=1 But the result is just the creation of the load step, but without setting the Analysis type:
  15. Hello! We have the following problem by using OSSmooth for a FEA reanalysis: Our component is made up of a core (blue) and a shell (red/orange). The core has Hex 8 3D-Elements with the Card Image MAT 1 and PSolid. In order to create a shell around the core of the component, we used the tool "Find Faces". Thus we got a shell around the core with Quad 4 2D-Elements. We used the Card Image MAT8 and PShell with an offset to the outside T=2mm. Therefore there should be no intersection between the two kinds of elements (see figure 1). Both the core and the shell was defined as design space so that we optimized them both in a successful optimization. See figure 2: Holes and notches were created in the shell as well as in the core. Afterwards, we tried to import the optimized geometry with OSSmotth by using the following settings: FEA Reanalysis, iso surface, remesh, trias as mesh type and two layers attached. As a result the 3D-Elements has been updated according to the optimization result, but not the shell (see figure 3). Furthermore we got a very questionably visualization of the shell elements: At the attachment points between core and shell, the shell elements strangely stick to the outside and inside (see figure 4 and 5). Are there any mistakes in our settings or in the modelling? Thank you very much in advance for your tips and advices! Greetings Martin
  16. Hi everyone, I want to validate the effects of residual stress and strain on the modal behavior of sheet metal. So, I did the forming simulation via Hyperform and I want to map the residual stress and strain results to Optistruct. Are there any way to do this ? Thanks. Best regards.
  17. Could you please advise me about property of welding element . I have to apply material property for welding element I can't find this value form the internet . Could you please help me
  18. Hi everyone, Trying to figure out how much volume fraction has to be given for meeting a specific modal target frequency of a automotive wheel while performing topology optimization. Just trying to find out the relation between volume fraction and modal frequency of wheel (wheel weight is 13 kg). For Example Target modal frequency of wheel should be above 400Hz. For meeting the modal target (above 400Hz) how much volume fraction value need to given in a single shot so that the modal target is met, in topology optimization of wheel. Thank you in advance.
  19. Hello again, since I have not received any answer, I have to repost this. I got a problem with my plies. I got a flange in my model where two face meet each other and combine to one. I want to use only one laminate, but I don't know how I can realize it. As you see in the picture, the plies are stacked only in direction of the normal. I got three faces, which I combined to sets: Inside (left side of the picture), outside (right side of the picture) and the flange. As elements for the plies I chose inside + flange on one hand, on the otherside I chose outside + flange meaning the flange should have the exact same structure as the inside and outside face, there should only be a 90 degree ply (dark blue) dividing them. I only want to use one laminate and one property. Is there any possibility to realize that? I tried to change it with the normals and z0 options, but it did not work. I hope I could explain it in an understandable way. If you need any other informations, please ask. Kind regards, Konstantin Heiss
  20. Hello, i am working with the optimization of the wheel disc. I have non design space weight as 7.14 kg and design space weight as 26 kg. I used mass constraint and had set the upperbound to 0.0035 (3.5 kg) and weighted compliance as my response. How ever when i used ISO with 0.3 the end weight of the design space came out as 4.7 kg. How does mass constraint works? can anyone please solve this concern. Moreover when i look the mass response graph it is showing almost the same value throughout the iteration. I have attched my output file, mass and compliance responce. Please explain me how mass constraint actually works? If mass value is same throughout my iterations, then how my stifness is reducing for both load cases? Thanking you Punith Guptha 2920774.out
  21. Hi There , I'm engaged in the project of chassis design for a vehicle for the FSAE competition and i have to make the chassis with a sandwich (CFRP - Foam) material , since hyperworks (OPTISTRUCT) will help doing the analysis , i started making a plate and making plies with CFRP (MAT8) and PCOMPP card image then a Core(MAT1) with PSOLID property , also i make laminate with the plies . i applied the load with constrains then loadstep with both and i check CSTRAIN and CSTRESS Properties for the analysis but since i start the analysis there is no iterations made and only the one displacement result appear , i tried alot to change in the structure but still no iterations , Here is what i have and there is a copy of the hm file attached The Results Iteration Subcase Variable Grid/Elem ID Value --------------------------------------------------------- 0 1 MaxDisp 12205 -0.285887E-02 0 1 MaxStress 5725 -15.0120 The amount of memory allocated for the run is 331 MB. This run will use in-core processing in the solver. ANALYSIS COMPLETED. ==== End of solver screen output ==== ==== Job completed ==== Sandwich Foam.hm
  22. I'm getting this error: A fatal error has occurred during computations: *** ERROR # 312 *** In static load case 1 the compliance is negative or large 1.33184e+018. Optimization/buckling analysis cannot be performed. due to possible rigid body mode. INFEASIBLE DESIGN (AT LEAST ONE CONSTRAINT VIOLATED). I'm thinking is a problem of units, but I have controlled very carefully all units. I've used: tonne, mm, N, Nmm, MPa in all steps. Thanks in advance for your time and help! apprada optimization_2.fem optimization_2.out
  23. Hi, I've previously had help from one of your colleagues with my model for which they suggested I do a Mesh-->Check--> Elements-->Penetration as I had a problem with my slide contact surfaces. I fixed the majority of these penetrations with the auto manager (not all were fixed) and tried to relaunch the calculation. However, now my model does not manage to converge and I don't fully understand why, even after reading up on all of the input fields in the contact menu. Any help would be greatly appreciated (model is attached)! Thanks in advance. 151207_MD_01_A-42.hm
  24. Hi Everyone, I'm performing shape optimization on a part, and I've run into the issue where after about 8-10 iterations the solver stops with the error of excessive element distortion. I've set the REMESH control card to 1 as suggested here: http://www.altairuniversity.com/wp-content/uploads/2015/06/REMESH_opti_control.pdf . However, when I do this the solver does iteration 0, outputs the excessive mesh distortion error, says that I have a feasible design (no stress constraints violated in the original part), gives me the "***** END OF REPORT *****" message, then says it's starting the remesh. It then proceeds to run the remesh on one core (I have 8) and takes forever (it's still running after an hour, but with very little RAM usage). Is this what's supposed to happen or am I doing something wrong? What I don't get is why it now says there is an excessive element distortion on iteration 0. Thanks! **Update: So the remesh finally finished (after about 2 hours) and the solver reloaded, but gave the following error: *** See next message about line 7281 from file: Shape_Opt_04_rmsh001.fem "SURF 2ELFACE" Syntax error(s) found in bulk data 'SURF' card. I have two contact surfaces in the model, not sure if that's the issue, as in the .fem file this line is right near the definition of the contact surface.
  25. Hi Everyone, I'm trying to fine-tune a topology optimized part using free shape optimization on some of the members. Unfortunately when I run Optistruct, it gives me the following: *** ERROR # 7312 *** DSHAPE card 1 contains 2 disconnected patches. Patch(es) listed below contain too few grids that are likely insufficient for defining a smooth surface/curve. I can't find anything on this error. Also, it doesn't list any "patches" so I'm not even sure where it's having problems. Any advice? Thanks! Size_Opt_Setup
×
×
  • Create New...