Jump to content

Search the Community

Showing results for tags 'command prompt'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Altair Support Forum
    • Welcome to Altair Support Forum
    • Installation and Licensing
    • Modeling & Visualisation
    • Solvers & Optimization
    • Multi Body Simulation
    • Conceptual design and Industrial design
    • Model-Based Development
    • Manufacturing Simulation
    • CAE Process Automation
  • Academic Partner Alliance Forum
    • APA - Composites
    • APA - CFD & Thermal
    • APA - Vehicle Dynamics
    • APA - Manufacturing
    • APA - Crash and Safety
    • APA - Noise, Vibration and Harshness
    • APA - System Level Design
    • APA - Structural and Fatigue
    • APA - Marine
    • APA - Optical Design
  • Japanユーザーフォーラム
    • ユーザーフォーラムへようこそ
    • Altair製品の意外な活用例
    • インストール / ライセンス / その他
    • モデリング(プリプロセッシング)
    • シミュレーション技術(ソルバー)
    • データ可視化(ポストプロセッシング)
    • モデルベース開発
    • コンセプト設計と工業デザイン
    • 製造シミュレーション
    • CAE プロセスの自動化
    • エンタープライズソリューション
    • データアナリティクス
    • 学生向け無償版(Altair Student Edition)

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Interests


Organization

Found 2 results

  1. Hello, I have a tcl script that uploads an FEM using ossmooth into hypermesh. Then two shrinkwraps are applied on the new iso-surface and the resulting mesh is exported as an stl file. The problem is when I call my script from the command prompt; hypermesh fails to locate elements by their property id. When I run the script in the hypermesh console no errors occur. Can anyone help me determine what is causing this strange behavior? The string sent to the command prompt is written as: "C:\Program Files\Altair\2019\hm\bin\win64\hmopengl.exe" -tcl "C:/Users/Eric/Documents/script.tcl" I cannot post the model because of work reasons. The script is below, the path names need to be updated with local file names: #the property id to locate design elements set design_id 23 #the voxel size for shrink wrap set wrap_size 0.0500000000 # .fem file path set fem_name "temp_name" # shape file results set sh_name "temp_sh_name" # the stl output path set stl_name "tmp_stl" #upload the file for fea re-anlalysis *createstringarray 2 "isosurf: 3 3 0.500000 0 -1 0 0 10 30 1 0" "other_params: 1 0 0 0 10 0" if { [ catch {*ossmooth_12 0 1 0 1 $fem_name $sh_name "" 1 0 1 2} ] } { puts "Error Extracting ISO-Surface..." } #mask all puts "Creating New Component" #create a new compoenet for the shrinkwrap set comp_name_1 "component1_lattice_wrap1" *createentity comps includeid=0 name=$comp_name_1 puts "Applying Shrinkwrap 1" #do the shrink wrap on the displayed elements *currentcollector components $comp_name_1 # # Script Error from command prompt # *createmark elems 1 "by property id" $design_id # # Script Error # *shrinkwrapmesh elements 1 2 $wrap_size 30 3 0 0 0 0 0 0 puts "Applying Shrinkwrap 2" #make another component for the second wrap set comp_name_2 "component1_lattice_wrap2" *createentity comps includeid=0 name=$comp_name_2 *currentcollector components $comp_name_2 *createmark elems 1 "by component name" $comp_name_1 *shrinkwrapmesh elements 1 2 $wrap_size 30 3 0 0 0 0 0 0 #divide the elems into triangles *createmark elems 1 "by component name" $comp_name_2 *splitelements 22 1 #export to STL into the predefined path puts "Printing the STL file" *createmark elems 1 "by component name" $comp_name_2 *createstringarray 2 "CONNECTORS_SKIP" "HMMATCOMMENTS_XML" hm_answernext yes *feoutputwithdata "C:/Program Files/Altair/2019/templates/feoutput/misc/triasto.stl" $stl_name 0 0 0 1 2 Thank you, -Eric
  2. Hello, I am trying to run optistruct from the command line in MATLAB. I have been able to run it using the line; system('"C:\Program Files\Altair\2017\hwsolvers\common\tcl\tcl8.5.9\win64\bin\wish85t_os.exe" "C:\Program Files\Altair\2017\hwsolvers\scripts\hwsolver.tcl" -solver OS -icon "C:\Users\e-tru\Documents\beam_maker_altair_44.fem"') But I also want to be able to output the element densities and .sh file after an optimization and have been unable to do so. I have tried invoking optistuct.bat to see if that would help me and used the line; system('"C:\\Program Files\\Altair\\2017\\hwsolvers\\scripts\\optistruct.bat" "C:\Users\e-tru\Documents\beam_maker_altair_44.fem"') Unfortunately it did not work and the following error was generated; ERROR in hwsolver script execution: couldn't write file "beam_maker_altair_44.err_39816.out": permission denied *************************************** What does this mean? How can the .sh file and densities .dens file be generated by calling the optistruct in the command prompt (in MATLAB)? My operating system is Windows 10, Hypermesh version 2017 and MATLAB R2017b. Thank you, -Eric
×
×
  • Create New...