Jump to content

Search the Community

Showing results for tags 'meshing automation'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Altair Support Forum
    • Welcome to Altair Support Forum
    • Installation and Licensing
    • Modeling & Visualisation
    • Solvers & Optimization
    • Multi Body Simulation
    • Conceptual design and Industrial design
    • Model-Based Development
    • Manufacturing Simulation
    • CAE Process Automation
  • Academic Partner Alliance Forum
    • APA - Composites
    • APA - CFD & Thermal
    • APA - Vehicle Dynamics
    • APA - Manufacturing
    • APA - Crash and Safety
    • APA - Noise, Vibration and Harshness
    • APA - System Level Design
    • APA - Structural and Fatigue
    • APA - Marine
    • APA - Optical Design
  • Japanユーザーフォーラム
    • ユーザーフォーラムへようこそ
    • Altair製品の意外な活用例
    • インストールとライセンス
    • モデリング(プリプロセッシング)
    • シミュレーション技術(ソルバー)
    • データ可視化(ポストプロセッシング)
    • モデルベース開発
    • コンセプト設計と工業デザイン
    • 製造シミュレーション
    • CAE プロセスの自動化
    • 学生向け無償版
    • エンタープライズソリューション

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Interests


Organization

Found 1 result

  1. Hi, I was trying to script meshing of bodies with a common sub-string in their names. I can use the below utility. But I cant figure out, how to use the variable in solid meshing syntax? Simlab Utility - var SubString1=["Bolt*"]; var EntitiesName29358=[]; SimLabUtility.GetBodiesWithSubString(SurfaceBodyName, SubString1, EntitiesName29358); Solid Meshing Code - I am trying something like this, but this doesnt works. //SurfaceBodyName is a variable storing model name var SolidMesh=' <VolumeMesher UUID="83822e68-12bb-43b9-b2ac-77e0b9ea5149">\ <tag Value="-1"/>\ <Name Value="VolumeMesher1"/>\ <SupportEntities>\ <Entities>\ <Model>'+SurfaceBodyName+'</Model>\ <Body>'+EntitiesName29358+'</Body>\ </Entities>\ </SupportEntities>\ <MeshType Value="Tet10"/>\ <AverageElemSize Value="3.5"/>\ <MaxElemSize Value="Default" Checked="0"/>\ <InternalGrading Value="2"/>\ <MinQuality Value="0.07"/>\ <LinearQuality Value="2"/>\ <MaxQuality Value="1"/>\ <QuadMinQuality Value="0.001"/>\ <QuadQuality Value="0"/>\ <QuadMaxQuality Value="1"/>\ <CadBody Value="0"/>\ <AdvancedOptions>\ <MeshDensity Value="0"/>\ <CreateVol Value="1"/>\ <Assembly Value="0"/>\ <PreserveFaceMesh Value="2"/>\ <MeshAsSingleBody Value="1"/>\ <Retain2DSurfaceBodies Value="0"/>\ <PreserveSurfaceSkew Value="55" Checked="0"/>\ </AdvancedOptions>\ </VolumeMesher>'; Simlab.Execute(SolidMesh); How to use the variable in place of body names?
×
×
  • Create New...