Jump to content

Search the Community

Showing results for tags 'normals'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Altair Support Forum
    • Welcome to Altair Support Forum
    • Installation and Licensing
    • Modeling & Visualisation
    • Solvers & Optimization
    • Multi Body Simulation
    • Conceptual design and Industrial design
    • Model-Based Development
    • Manufacturing Simulation
    • CAE Process Automation
  • Academic Partner Alliance Forum
    • APA - Composites
    • APA - CFD & Thermal
    • APA - Vehicle Dynamics
    • APA - Manufacturing
    • APA - Crash and Safety
    • APA - Noise, Vibration and Harshness
    • APA - System Level Design
    • APA - Structural and Fatigue
    • APA - Marine
    • APA - Optical Design
  • Japanユーザーフォーラム
    • ユーザーフォーラムへようこそ
    • Altair製品の意外な活用例
    • インストールとライセンス
    • モデリング(プリプロセッシング)
    • シミュレーション技術(ソルバー)
    • データ可視化(ポストプロセッシング)
    • モデルベース開発
    • コンセプト設計と工業デザイン
    • 製造シミュレーション
    • CAE プロセスの自動化
    • エンタープライズソリューション
    • 学生向け無償版

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Interests


Organization

Found 3 results

  1. Hi all, I created macro auto adjust normals: proc adjust_normals {} { *createmark comps 1 all *createmark elems 2 "by config" quad4 tria3 set List_comps [hm_getmark comps 1] for {set n 0} {$n<[hm_marklength comps 1]} {incr n} { *createmark elems 1 "by collector" [lindex $List_comps $n] *markintersection elems 1 elems 2 if {![hm_marklength elems 1]} {continue} else { set List_elems [hm_getmark elems 1] set ID_elems_ori [lindex $List_elems 0] *normalsadjust elems 1 $ID_elems_ori 0 0 } } *normalsoff hm_usermessage "Done." } but it doesn't work in some case, such as seperated components... Please suggest a way to improve it.
  2. Hi, I am trying to create a tcl script that is supposed to find the element normal direction for a component/body. I want to run the script in batch mode and obtain the output (normal direction) in a text file. Is there any way I can achieve this? Please refer to the attached snapshots for better understanding. Note: All element normals for a particular body are in the same direction. Thanks & Regards, Roshan
  3. Hi, How do i normalize the elements using a specific vector direction? Regards, SriGanesh.
×
×
  • Create New...