Jump to content

Search the Community

Showing results for tags 'surfaces'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Altair Support Forum
    • Welcome to Altair Support Forum
    • Installation and Licensing
    • Modeling & Visualisation
    • Solvers & Optimization
    • Multi Body Simulation
    • Conceptual design and Industrial design
    • Model-Based Development
    • Manufacturing Simulation
    • CAE Process Automation
  • Academic Partner Alliance Forum
    • APA - Composites
    • APA - CFD & Thermal
    • APA - Vehicle Dynamics
    • APA - Manufacturing
    • APA - Crash and Safety
    • APA - Noise, Vibration and Harshness
    • APA - System Level Design
    • APA - Structural and Fatigue
    • APA - Marine
    • APA - Optical Design
  • Japanユーザーフォーラム
    • ユーザーフォーラムへようこそ
    • Altair製品の意外な活用例
    • インストールとライセンス
    • モデリング(プリプロセッシング)
    • シミュレーション技術(ソルバー)
    • データ可視化(ポストプロセッシング)
    • モデルベース開発
    • コンセプト設計と工業デザイン
    • 製造シミュレーション
    • CAE プロセスの自動化
    • 学生向け無償版
    • エンタープライズソリューション

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Interests


Organization

Found 11 results

  1. Hi all, I have imported geometry from a CATPart into HyperMesh and now I am trying to get the names of the surfaces in the model. I am using following commands and till now have no success. (I can get the IDs of surfaces e.g. 1,2,3,4 ..) *createmark surfs 1 all set surfsList [hm_getmark surfs 1] hm_getentityvalue surfs 2 name 1 -byid The first two commands return results (hm_getmark returns the IDs of surfaces: 1,2,3,4,5). However the last command (hm_getentityvalue from Reference manual) doesn't return anything at all, (not even any error). My goal is to get the names of the surfaces (via any Tcl command). I will be very thankful for any help. Best regards, Mubeen
  2. Hello everyone! I now trying to find surface 2 and surface 3 that they are pairs of opposite surfaces to surface 1. Suppose we get a virtual straight line cross centroid of surface 1 parallel to surface 1's normal vector, I want to find first and second surfaces that have shortest distance to surface 1 alone the virtual line, in this example ,they are surface 2 &3 "hm_measureshortestdistance" can only find surface 5 and surface 6 because they are closer than surface 2&3 I tried to Create temp node attached to surface 1 located in centroid(hm_getcentroid surfs) of surface 1,duplicate the temp node and then project the duplicated node to solid surfs with normal option(*markprojectnormallytosurface) ,in order to get distance list of nodes, the original temp node and duplicated nodes distance list.By using lsort -increasing -real $distancelist , I got first two distance and find surface 2 & 3 that opposite to surface 1. But.it's really complicated and the script runs really really slowly Is there any efficient way to get surface 2 & 3? I'm really really sorry that I'm not good at English. Thanks in advance!Thanks for your Great patient! @tinh @vipin slide0.bmp
  3. Hi all, I am trying to find duplicate surfaces in a model. I couldn't find any Tcl command for searching duplicate surfaces, however there is following Tcl command from HyperMesh Desktop Reference Guide which searches faces: *createmark faces 1 all *facepreviewduplicates 1 0.1 In the status message bar, the message "5 faces are duplicate" appears. However my target is to find out the pairs of duplicate surfaces. Is it possible using HyperMesh Tcl? Best regards, Mubeen
  4. Hello, I'm using HyperWorks 13.0 Student Edition and suddenly a hm file started to take minutes to open or to edit anything (specially surfaces). When I try to mesh something the program enter the mode "Not responding". What is that? What should I do? I've already tried to save as another file, to import then save, to restart my computer, to clean my temporary files, etc... But i think that the model has some problem. Thank you.
  5. Hello, I have a model which includes several surfaces that I need to appear on the postprocessing stage as rigid surfaces. Those aren't meshed since I don't need to resolve for any quantities on them, I just need them to be on my model to be displayed on the results. Here's an image where those surfaces are shown in yellow. Does anyone know how to accomplish that? Thank you in advance.
  6. Hello community, I have a question concerning to apply loads and constraints on 3D surfaces. I have created a solid model from a 2D surface. If I do a 3D multi solid mesh and apply the constraints and the pressure onto the two surfaces (see figure 1), I will get a result. And I can see that every node on the surface is constrained and all elements on the surface are applied with a pressure force. If I create a 2D mesh first and drag the elements along the thickness of the model for a 3D mesh and then apply the constraints and pressure onto the surfaces, I will get no results. And further I can see that not all nodes on the surface are constrained and not all elements on the top surface are applied with a pressure force although I have selected the two surfaces (see figure 2). Why can't I apply the constraints and pressure on surfaces if I create a 3D mesh from a 2D mesh? And why is it possible if I mesh the model with the multi solid subpanel? Thanks in advance.
  7. Hi everyone, I am doing a project for the subject of aerodynamics and I am using AcuConsole for that. I am finding some problems with the CATIA reader I have installed with AcuConsole, so I am thinking now switching the file format to stl (seems more reliable). The problem I am finding now is that I cannot split the model into different surfaces, to assign the airfoil, the sides, etc. I tried to divide the geometry with the feature angle, changing it from 90 degrees to 0.1 and doesn't allow me to pick up any geometry when I create a new surface group. Could you help me to solve that problem? I attached the files if anyone wants to try. Thank you beforehand. Guillermo Flow Domain.stl
  8. Hello, I would like to do some lattice optimization in Hypermesh. However, I need to know if it is possible to have a different mesh size for the lattice sections compared to the solid sections. The way I understand lattice optimization in Altair is that the element size you mesh with originally will determine the average length of the lattice struts. For example; I tetra mesh my model with a size of 2, the lattice beams have an average length of 2. However, I would like to have a mesh size of 0.5 with lattice elements of length 2 (or vice versa). My game plan is to run a minimize compliance with volume fraction on my model with a penalization of 1.8 (low porosity). Then use the results of the compliance optimization to split my part into sections for a given element density threshold. I should end up with solids for the lattice elements and solids for the non-lattice elements. The lattice solid sections will then be filled with lattice beam elements from another lattice topology optimization. I want to remesh each solid individually for different lattice strut sizes and types. Contact surfaces will then be used to connect the solids together and then run the Lattice optimization. The end goal is to use mesh refinement on the non lattice sections to check the validity of my model as well as experiment with different lattice sizes. Any advice is greatly appreciated. -Eric
  9. Hi all, Is there any command available to find surfaces which are very close to each other. I have 2 components and there are some locations where the surfaces are really close(like contacts), need to find these surface ids without any manual selection.
  10. Hi All how should I choose the external surface of a spherical shape as a surface , when I also have meshed it ? I tried elements but the problem was that I could not use any option to select all the elements on the external surface, options like adjacent ,etc don't work
  11. Hello, I have a model which includes several surfaces that I need to appear on the postprocessing stage as rigid surfaces. Those aren't meshed since I don't need to resolve for any quantities on them, I just need them to be on my model to be displayed on the results. Here's an image where those surfaces are shown in yellow. Does anyone know how to accomplish that? Thank you in advance.
×
×
  • Create New...