Jump to content

Search the Community

Showing results for tags 'tetramesh'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Altair Support Forum
    • Welcome to Altair Support Forum
    • Installation and Licensing
    • Modeling & Visualisation
    • Solvers & Optimization
    • Multi Body Simulation
    • Conceptual design and Industrial design
    • Model-Based Development
    • Manufacturing Simulation
    • CAE Process Automation
  • Academic Partner Alliance Forum
    • APA - Composites
    • APA - CFD & Thermal
    • APA - Vehicle Dynamics
    • APA - Manufacturing
    • APA - Crash and Safety
    • APA - Noise, Vibration and Harshness
    • APA - System Level Design
    • APA - Structural and Fatigue
    • APA - Marine
    • APA - Optical Design
  • Japanユーザーフォーラム
    • ユーザーフォーラムへようこそ
    • Altair製品の意外な活用例
    • インストールとライセンス
    • モデリング(プリプロセッシング)
    • シミュレーション技術(ソルバー)
    • データ可視化(ポストプロセッシング)
    • モデルベース開発
    • コンセプト設計と工業デザイン
    • 製造シミュレーション
    • CAE プロセスの自動化
    • 学生向け無償版
    • エンタープライズソリューション

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Interests


Organization

Found 26 results

  1. Hi! I'm trying to mesh a solid with TetraMesh and it states the following error: "2 edges failed nodal setup. Meshing failed". But I can't see anything wrong or red colored or anything that tells me where the mistake is. Even with visualisation options. The solid is created properly with bounding surfaces so I guess there are not free edges. Could you help me?
  2. how to subtract two tetramesh components from one another in hypermesh? I was having stl files, then I have converted them into 3D tetramesh. Now i want to subtract volume of one part from other.
  3. Hello, I would like to tetra mesh my component from a 2D mesh of trias that already exists. The 2D mesh must remain constant as it has a load applied to it that cannot be changed. The problem I am having is that the tetra mesh option 'fixed trias to tetra mesh' produces large size elements in the middle of the model. I would like to constrain the maximum size of the 3D tetra mesh so its does not increase in size in this way. Is this possible? Thank you in advance
  4. Hello, I have a query regarding the generation of core mesh in hypermesh cfd. Why it is necessary to have only tetra core meshing? Is it the requirement for hypermesh or in others also for cfd core must have tetras.
  5. I imported a 3D solid element. When I supposed to mesh using Tetramesh, only surface mesh alone be used to mesh. I cant use Solidmesh. May i know the reason please... Thank you in advance.
  6. Hi everyone, please help me. I have a STEP file contains 5 components, and this STEP file is exported from Solidworks. The 5 components in the STEP file are a, b, c, d, e. a, b, c are in contact. c, d, e are also in contact. I want to make the meshes between components are connected. So I ues solid edit --> boolean to create shared surfaces between components that are in contact with others. the details about solid edit --> boolean is as follows: operation type: advanced operation: A+B combine through: none I do it for 6 times which are: 1. A: a B: b 2. A: a B: c 3. A: b B: c 4. A: d B: c 5. A: e B: c 6. A: d B: e I'm not sure if this is the proper way to create shared surfaces for the 5 components. Next, I use 2D --> automesh --> QI optimization. I also tried surface deviation and edge deviation, but the results are not good. The problem is that some meshes from two different components formed on one same surface. Like the figure attached. So those two components can't formed a closed volume and it leads to failure of tetramesh. My whole modeling process are going to be built automatically by tcl script, so I can't manually delete those overlapping meshes. Maybe delete the overlapping meshes by tcl script can help, but I have no idea how to do it. I upload a zip file, which contains three files: 1. test.STEP : This is the raw STEP file that contains 5 components. 2. fail.hm : Already imported the test.STEP file, but have'nt done anything further. 3. good.hm : A model that is successfully done. This is a similar model, and my final goal is to built a model like this. model.rar
  7. Dear all, I am working as NVH engineer. in our case , we use terta solid mesh. my process : first we will make tria mesh and then we will convert into tetra mesh using ( 3D--> Tetramesh--> tetra mesh --> fixed trais/quads to tetra mesh --> simple pyramid --> create per-volume comps --> create. Then the tetramesh will create in a component vol001 ( name of the newly created component). so i need to delete the 2d mesh component and also again i have to rename the component . so i want to simplify my process. i want to create TETRA MESH (3D) in same component where the TRIA elements (2D) are present. but by deleting the 2D tria elements (automatically) during the tetra-mesh conversation process. ??? IS THIS POSSIBLE ? please give your suggestion. so that i can save some time. becoz for every item i need to rename for more than 50 components. thank you.
  8. Hello, I encountered the following problem: after creating a 2D surface mesh on all surfaces of a solid I used tetramesh. Afterwards I reorganized the meshes so that the tetramesh belonged to the component of the original geometry and the 2D mesh was deleted. When trying to apply a line load onto the new tetramesh the following error occured: Lines are not attached to edge elements. I also tried to select the nodes by geometry and selected the desired line but my selection of nodes was not accepted. On the previous 2D mesh the line load worked fine. Do I have to actively attach the new tetramesh to the geometry or do so while creating the tetramesh? Or am I doing anything wrong when creating the tetramesh, so that the lines for line load wouldn't be accepted? Thanks in advance
  9. Hi everyone, I'm working on a volume and want to mesh it with tetrahedral meshes, I have meshed surfaces of this volume, How can I create tetrameshes for the whole volume? P.S. meshes on surfaces are fixed and should not be changed. Thanks a lot
  10. Hi, Could you help me to make this transition mesh work? I need to fill the space between the larger and smaller cube. I know that I need to close the front face to have a closed area to be able to use tetramesh to fill it (correct me if I'm wrong) but after closing it with tria elements (last figure) and trying to do the tetramesh, it gives me "A segmentation error occurred" message and crash close my model. I'm using Abaqus as a solver and this is part of a fatigue analysis model. Thanks, Maysam
  11. Hello, i try to mesh a Wing for CFD Analysis with VWT. In the Analysis of the Mesh i have a lot of intersections and the automatic fix is not working. The Endplates are out of Solids. The rest of the Wing is out of Surfaces. I deleted the solids and kept the surfaces of the solids but there was the same problem again. How can i remove those self intersections? (see dropboxfile) or Is there maybe a way to trim components with other components and merge the surfaces of those components? Mesh: https://www.dropbox.com/s/vqmqcbc4o0fpayl/FrontWing.hm?dl=0 (CAD modell http://www.dropbox.com/s/fn9f7msqx0cowta/frontwing.IGS?dl=0 )
  12. Hello, I am trying to use TCL code to automate the tetrameshing process due to a large number of individual components needed to be meshed for CFD. I am using a simple right angled pipe and have a variation of code that was given in the "Hyperworks Desktop Reference Guide". I can successfully use the tetramesh process within Hypermesh itself manually, selecting my "Wall" as With BL (Fixed) and my "Inflow" and "Outflow" as W/o BL (Float) and do not have the issues that I will explain. However, when I try and automate the process using TCL code, my "^CFD_trias_for_tetramesh" part is only a 2D mesh. This then results in the following failure when using the AcuSolve job launcher: "No Valid 3D element found in the neighbourhood of a tria element". Whereas, if I was to do this manually, the part would be called "CFD_tetcore001", however it would be a 3D volume mesh. Here is my code: *createstringarray 2 "tet: 21532 1.2 2 0 0.8 0 0" "cfd: 86 0.0035 22 1.2 1" *createmark comps 2 "Inflow" "Outflow" *createmark comps 1 "Wall" *tetmesh comps 2 0 comps 1 3 1 2 Would anyone be able to provide any suggestions as to how to get a 3D mesh in the centre of the fluid. Thanks, James
  13. Hello, I have a query regarding the generation of core mesh in hypermesh cfd. Why it is necessary to have only tetra core meshing? Is it the requirement for hypermesh or in others also for cfd core must have tetras.
  14. I was wondering why I get some messed up mesh (and consequently some free faces flying around, marked in the screenshot) when I use tetra remesh to take care of tetra collapse and other element check factors. I need to mesh the transition layer you see in the attached screenshots. When I tetramesh it, it's ok and no free edges/faces. But after remeshing the tetramesh locations with problematic tetra collapse, I end up with some weird elements protruding to others and some free edges/faces that even equivalence couldn't get rid of them! Any help/idea is greatly appreciated. Also let me know if you know a better way to mesh this transition than tetramesh (the area of the inner squares are 1/4 of outer squares). Thanks a lot, Maysam
  15. Mushi

    Tetramesh

    Dear all, I have a problem with the aftermath of tetrameshing. I have two different parts which can be imagined as a hamburger. The outer layer is bread and the inner layer is beef. I have to tetramesh them into two different parts so that I can assign different material properties to them respectively. But when I tetrameshed the parts one by one, they will end up with only one tetramesh model. How can I separate them into two different tetrameshed solid parts? Your help is greatly appreciated and thanks in advance. Kind regards, Mushi
  16. Hello all, I am from a Geophysics background and I am attempting to use HyperMesh to generate a FE Mesh of some basic reservoirs containing different fracture or fault geometries I am trying to mesh a a simplified model of a reservoir (volume) with two embedded intersecting faults (surfaces). I attached a picture of my simple geometry to give you an idea. I need the finite element mesh for flow simulations, however the simulation requires that the triangle elements of the fracture surface have shared nodes with the tetrahedron elements of the volume. I was able to generate a mesh successfully, however it does not seem to have shared nodes because when I run my simulation there is no communication (fluid flow) between the fracture and the rest of the volume. Can anyone help me with this issue? Is there a particular setting that I need to use to ensure that there are shared nodes between the surface and volume elements. Currently, I mesh the surfaces first, using 'Create 2D AutoMesh' then create the volume around it and I mesh that using 'Tetra Mesh' I would greatly appreciate any feedback you can give on this. Thanks, Ariel
  17. Hi, I used the "Tetra Mesh" function to generate a 3D tetramesh from a surface shell mesh (tria elements). However, I noticed that after the tetramesh was generated. The surface shell mesh remains. Is it possible to somehow remove the tria shell elements while/after generating the tetra mesh? I have a nodeset that I would like to retain over this process. I tried generating the tetra mesh in a separate component and then delete the original shell mesh component to keep the tetra elements only. However, the nodeset was also deleted after removing the shell mesh. Cheers, Wensong
  18. Hi, May I get some advice on the meshing skills from 2D to 3D meshing? 1. How should I deal with the end of this triangular shape? The element at the end must be low quality. 2. For this triangular shape, should I use mix mesh as above or use R-trias shape? Which one would benefit me in tetramesh in the following steps. In general, what is the different between common trias and R-trias elements? Do they have some advantage in some specific application? 3. How should I deal with the two ends of right triangle with curve hypotenuse? These two ends are sharp corner. 4. For this long surface, should I use equal number of elements at the red labelled lines? If the elements number are equal, only Quads would be created. If not, and use default number, the longer side would get more elements. Which situation would benefit the 3D tetramesh? 5. For the similar situation, how should I deal with this surface to get a better mesh? What shown is the result for simple mix mesh. 6. Which kind of 3D mesh would get better result in similar number of elements, 3D tetramesh or 3D hexamesh mixed with tetramesh. To put it in this case, which 3D meshing would be more accurate, 1- split the quads into trias for tetramesh; 2- mainly hexamesh combined with tetramesh. 7. How should I construct the hexamesh combined with tetramesh? Thank you for your advice.
  19. Hello, I am working on setting up a model for a simple topology optimization and I am consistently running into the same error when trying to form a mesh. I have meshed the entire design space and part of the non-design space but the final solid always results in an error of "1 edges failed nodal setup. Meshing failed". I have not been able to find any information about this error online so far. I have attached a photo of the error message and a photo of my model prior to meshing. The attached model includes the failed mesh as a "tmp" component. Is there an error in my geometry? How would I be able to mesh this final solid? Thanks ComparisonStudyModel.hm
  20. Hey Guys, I had problem several times in the past with the 3D tetrameshing. My mesh on the surface is pretty good, you can see the mesh criteria file settings on the attached picture, but my 3D tetramesh isn't good enough. There was error during element check. (I know I can turn off element check, but I want to make a good 3D mesh). Therefore I would like to ask guys, that give me a criteria file, that will be good enough for 3D tetramesh. Thanks for your advice in advance!
  21. Hello, I am trying to mesh a fairly complex geometry. I am doing simulations of a fractured reservoir. My geometry is a box which represents the rock mass and a number of variably oriented planes contained within the box which represent fractures. I have successfully meshed the planes using 2D Auto Mesh. I would now like to mesh the volume with tetramesh however it is very important that the tetra elements and the tria elements have shared nodes. I have attached a screen shot of the geometry to give an idea of what it looks like. You can see the meshed fractures and the containing box. I tried using tetramesh but I got an error message stating that the mesh is not enclosed. I am not sure if I selected the correct options. Can someone please advise on the best way to get this done.
  22. When meshing with Tetra Elements, HyperMesh fails with the error message "Volume Analysis failed". There remains a "tmp_2d_for_tetra"-Component. However there are not hints, where the mesh is incomplete or corrupt. I suppose there is a small gap in the mesh, which I can not see. Is there a way to find the critical areas for tetrameshing?
  23. Hi ! I'm trying to find the drag force of the air on a sphere. I'm using MLAW6 with the k-epsilon model on a tetramesh for the air, and M11 BOUND for the bound on a cubic mesh, the sphere is meshed with shells and put in a rigidbody. I chose an eulerian formulation (i also tried ALE..)ter I imposed a velocity of 10m/s on the first row of nodes of the air. I used the interface TYPE18 with a gap larger than 1.5times the element size to be sure it works. Master : sphere, slave : air But i still have the error : TIME STEP LESS OR EQUAL DTMIN FOR SOLID ELEMENTS This is strange because when the air is meshed using a cubic mesh it works quite well (even though i usually get a drag force about twice as large as what i calculated myself with the formula) Any ideas why it doesnt work ? and how i could make it work ? Thanks Matt
  24. Hi guys, I find there is some bug in tatramesh with hm 2017 while it is ok in hm14.0. For the same solid, after I split it with same params, and then mesh the solid body, the number of node and elements are different each time in hypermesh 2017.2; But in hm 14, It OK The steps I do as follow: 1\open hypermesh 2\import utg model (attachment) 3\split the solid with X-plane-(0 0 0) 4\mesh the solids 5\remember the number of the node and elements 6\repeat 1-5 and compare with the first number. How to fix this problem ? Thanks . solidTest_ug.prt tetrameshProplem.wmv
  25. hello everybody, i have to do an aerodynamic simulation of a race car and i ve done the 2d surface mesh of the shell and of the box (there aren t free edges or t junction). now i ve to do the tetramesh to simulate the fluid domain but it fails all the time and i don t know why.. someone can help me?
×
×
  • Create New...