Jump to content

SPH- Smoothed Particle Hydrodynamics

Recommended Posts


I want to create sph in the half of the box, outside the pipe ( a photo was attached).( I do not want to have sph inside the pipe). I used automesh to mesh them as well.

I selected the box and pipe and then in volume definition I selected pipe as an exclude enclosed. But the sph was not generated and I got an error which says '' No volume selected for meshing''.

would you please help me.

I appreciate your help.




Share this post

Link to post
Share on other sites


Unfortunately there are some issues related with "Exclude enclosed" option in HyperMesh and our developers are working on it to get in fixed in the next release.

As for now, you have to create SPH elements throughout the box and manually delete those inside the pipe surface.


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...