Jump to content
Sign in to follow this  
Rahul Ponginan

Intel MPI Problem

Recommended Posts

Hej,

AcuSolve is running fine until I try to use acuRun to solve my CFD Problem. The log file tells me, that there is a problem installing the SMPD service or Intel MPI. I tryed to install it manually and it is listed in my host services. So it should be installed, but the error remains.

Any Ideas?

Best regards,,
Burkey

System:
Windows 8 64 bit
4GB RAM
Ati Radeon 6990
Altair Hyperworks 12.0

Altair Hyperworks doesn't support Windows 8 as I know, BUT in my Virtual Mashine, running Windows 7 64 bit, the error also appears.

Share this post


Link to post
Share on other sites

SMPD issue arises due to User Account Control in Windows 7+.

Please see if the methods suggested in the following post help to resolve this issue:

http://www.altairuniversity.com/2013/06/26/acusolve-and-windows-operating-systems-tips-tricks/

--------------------------
Depending on what level of notifications is set in the User Account Controls, the automatic installation of the service may fail, and AcuRun will tell you that you need to install the service manually to proceed. At this point, users have 2 options:

1.) Reduce the level of notifications in the User Account Controls, then let AcuRun automatically install the service next time you run a simulation. 2.) Right-click on the AcuSolve command prompt, select Run as Administrator, then install the service using the “acuRun -ismpd” option.

For extremely restrictive user environments that do not allow users to install software on their systems, this will need to be performed by the person that installed AcuSolve on the system. Note that this process is detailed in the HyperWorks 12.0 Installation guide in Section 5.2d “Configuring MPICH and Intel MPI on Windows Platforms” (Febuary 15, 2013)

Share this post


Link to post
Share on other sites

Try running "acuRun -ismpd" as Admin, in a case directory (this folder would have Acusim.cnf, case.inp MESH.DIR etc.)
Currently you are running in bin folder, where AcuSolve is installed.

In case above mentioned steps do not help, try:

1. Use AcuConsole to export AcuSolve input file (.inp) using Tools-> Export.
2. Open AcuSolve command prompt and go the case directory. Type: acuRun -mp openmp -np 2

This method would test if openmp works, instead of intel-mpi.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...