Jump to content
Sign in to follow this  
Rahul Ponginan

Python.exe failure

Recommended Posts

Hello HWSupport-Team,

1.) I am using Altair Hyperworks for a study project at University
Unfortunatelly I have a problem with importing the geometry I use to AcuConsole.
It is not possible to import IGS or STEP files to this tool. So I thought I could use a CAD-software like ProE/Creo to change the file-type.
So I used different file types like ProE-Part, Parasolid and STL, but everytime I get a different failure.

If I use ProE-Part Filein AcuConsole I get an Python.exe failure and the system crashes. So it is not possible to import this kind of file, though it says I can use it.

If I use Parasolid-file type it starts to import the file but then it says: „zero-sets found“. What does this mean!? I checked the geometry in my CAD-software but everything for me seems to be fine.

The same with STL-file type.

My system:
Windows 7 (64 bit)
AMD Phenom II 940 (4x 3,0 Ghz)
4GB DDR2 Ram
ATI Radeon 6970 graphic card

Do you need more information of my system to work with?

Thanks for your help and best regards,
Burkey

 

Share this post


Link to post
Share on other sites

Hi Burkey

It is very important to make sure the model is watertight i.e. no defects and it should be a closed volume when you import into acuconsole.

Please check if the model can be imported into HyperMesh,

If it can be imported into HyperMesh then check for duplicate surfaces and free edges etc and make sure the model is watertight.
see http://altair-2.wistia.com/medias/kfwh100trm

As a workaround to continue your work now you can actually create a close surface mesh in HyperMesh > export as .nas and then import this into Acuconsole

Another thought about your other errors, did you by any chance get a unicode error with some of the file types you tried?
I am afraid AcuConsole can only read standard English (ASCII) characters, try avoiding non English characters in the path name or in the database.

Please follow the above exactly and if there is no success please send me the model using the dropbox link below, I am also curious to know if the model has solid volumes?

Share this post


Link to post
Share on other sites

Hi Burkey,


The model has very detailed features and a few defects. You can either repair the geometry in your CAD software or alternatively work around it as below


As explained you will have to first Delete > solids > without the bounding surfaces


Go to geom > defeature > duplicates > all surfaces selection > find duplicates > delete. (you will find 8 duplicate surfaces)


Then find and repair the geometry for free edges using quick edit for example


you can then surface mesh the geometry with a small element size like 0.001


Then eliminate any free edges using tool > edges


Export this mesh as a .nas file > import into acuconsole.


Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...