Jump to content
Sign in to follow this  
Guest

how to solve the ZERO OR NEGATIVE VOLUME problem when using very soft material?

Recommended Posts

Guest

Hi,

I am trying a simple impact analysis like radioss example 26 ruptured plate ( I am not interested in the rupture, just want to try an impact problem). I am using a soft non linear material M36_PLAS_TAB with a stress strain curve (E=8Mpa,nu=0.42,rho=1.412e-6Mg) and fixing the whole bottom surface. I used the volume tetra mesh to mesh my disk. ( I am using solid elements instead of shells as a basis for a more complex problem I am working on)

The model was working fine with linear elastic materials...

I read a few posts about this problem. There it was suggested to use a really thin linear elastic surface on top.
And to change the element formulation.

Could you please elaborate more in detail the steps to overcome this problem?

Thanks!

Share this post


Link to post
Share on other sites
Guest

We have some FAQ about this error message depending when you get the error message, Is it for the starter? does the error also include an element ID or element description?

When you change the element formulation, card edit the property and then choose ismstr to 2 along with timestep variation as explained in detail in the FAQ below.

Navigation: Altair RADIOSS > RADIOSS Frequently Asked Questions > Elements
I used solid elements and the run stopped before the end time, with the message: "Zero or Negative Volume". How do I solve this problem?

Navigation: Altair RADIOSS > RADIOSS Frequently Asked Questions > Elements
I used solid elements with Ismstr=2 and /DT/BRICK/CST; but the run stopped with the message: "Zero or Negative Volume"; is this normal?

Navigation: Altair RADIOSS > RADIOSS Frequently Asked Questions > Elements
I used solid elements and several integration points, and the Starter gives the following error message while the element seems to be well-defined: ** ERROR: ZERO OR NEGATIVE 3D SOLID VOLUME, is this normal?

Share this post


Link to post
Share on other sites
Guest

I tried using Isolid=14 and 24 and used Icpre to 2.
But still the error remains..:
MESSAGE ID : 166
** STOP : ZERO OR NEGATIVE VOLUME FOR 3D-ELEMENT ID=18219
ERROR TERMINATION

Share this post


Link to post
Share on other sites
Guest

ow to use the HA8 formulation? I am using block51 format. I don't see Inpts option in the card edit window..


Share this post


Link to post
Share on other sites
Guest

Arbhaval,

If you are using tetrahedron elements you should perhaps not change the Isolid value,

The Isolid flag is not used with 4- and 10-node tetrahedron elements. For these elements the number of integration points is fixed (1 and 4, respectively).

Read the last FAQ topic -
In the RADIOSS Starter input file (Runname_0000.rad), use Ismstr =2 in the solid property or in the option /DEF_SOLID; in RADIOSS Engine file (Runname_0001.rad) use the option /DT/BRICK/CST

Share this post


Link to post
Share on other sites
Guest

I tried using Icpre=2 with a combination of Ismstr=2, No Isolid; No Ismstr , No Isolid . I also tried Isolid=0,1, But no luck yet.. I am using DT/Brick/CST with 0.6Tscale and 5e-7Tmin

NC= 0 T= 0.0000E+00 DT= 1.2600E-04 ERR= 0.0% DM/M= 0.0000E+00
ANIMATION FILE: similartoes26zsorbothane100kgpvelA001 WRITTEN
-- CONSTANT TIME STEP FOR SOLID ELEMENT NUMBER 16954
-- CONSTANT TIME STEP FOR SOLID ELEMENT NUMBER 17763
-- CONSTANT TIME STEP FOR SOLID ELEMENT NUMBER 11585
-- CONSTANT TIME STEP FOR SOLID ELEMENT NUMBER 13442
-- CONSTANT TIME STEP FOR SOLID ELEMENT NUMBER 16598
-- CONSTANT TIME STEP FOR SOLID ELEMENT NUMBER 16945
-- CONSTANT TIME STEP FOR SOLID ELEMENT NUMBER 17318
MESSAGE ID : 166
** STOP : ZERO OR NEGATIVE VOLUME FOR 3D-ELEMENT ID=18218
MESSAGE ID : 166
** STOP : ZERO OR NEGATIVE VOLUME FOR 3D-ELEMENT ID=18702
ERROR TERMINATION
ERROR TERMINATION

==== End of solver screen output ====

I also tried using Ismstr=1,Icpre=2,No Isolid and it gave me no errors. But the sphere passed through the disk. I got normal termination with this combination. But I don't know if the results are valid/practical?This was the solver output:
NC= 0 T= 0.0000E+00 DT= 1.2600E-04 ERR= 0.0% DM/M= 0.0000E+00
ANIMATION FILE: similartoes26zsorbothane100kgpvelA001 WRITTEN
ANIMATION FILE: similartoes26zsorbothane100kgpvelA002 WRITTEN
ANIMATION FILE: similartoes26zsorbothane100kgpvelA003 WRITTEN
ANIMATION FILE: similartoes26zsorbothane100kgpvelA004 WRITTEN
ANIMATION FILE: similartoes26zsorbothane100kgpvelA005 WRITTEN
ANIMATION FILE: similartoes26zsorbothane100kgpvelA006 WRITTEN
ANIMATION FILE: similartoes26zsorbothane100kgpvelA007 WRITTEN
RESTART FILES: similartoes26zsorbothane100kgpvel_0001_[0001-0001].rst WRITTEN
NORMAL TERMINATION
TOTAL NUMBER OF CYCLES : 170

Share this post


Link to post
Share on other sites
Guest

I also tried to solve the warnings of 'incompatible kinematic conditions' but couldn't.. I read about it in the help and tried to add one more rigid wall but I am not able to get rid of these warnings.. Please give me some suggestions..


Share this post


Link to post
Share on other sites
Guest

i,


Remove the constraint in Z direction. In your model a boundary condition and imposed velocity are in same direction. for more information on Kinematic condition please refer to FAQ in Help. icon_smile.gif


Share this post


Link to post
Share on other sites
Guest

es, I am trying to analyze the impact of the ball on the foam material.
I tried this impact in 4 models each with different materials. Now I have combined all of these materials (using type 7 interfaces with csurfs and node sets) and want to run the analysis.
I didn't get any errors. But the solver is taking long time to run. I assume this is comparatively a simple analysis. So I might be doing something wrong. Maybe in the engine file definition. Can you please take a look and give any tips? I am sending the model file by dropbox.
Thanks!

Share this post


Link to post
Share on other sites
Guest

Hi,


there are 2D scattered elements in your model, please delete and re-configure the master surface and slave nodes.


Share this post


Link to post
Share on other sites
Guest

Hi,
Thanks. I am able to get results and animations with a normal termination. But from the animation, it is clear that I am making some mistakes probably in my use of contacts. I read the General Purpose Interface (/INTER/TYPE7) help and think I should follow the Soft Part Against Hard Part technique. I don't know how I should calculate the stiffness values and what flags to use in the contact definition. Can you please advise me?

Share this post


Link to post
Share on other sites
Guest

i,


in TYPE7 card, change the Istiff to 4 and run the analysis. you can also specify a stiffness factor (STFAC)


Istiff 4 takes the minimum stiffness of master and slave.


hope this helps icon_smile.gif


Share this post


Link to post
Share on other sites

Hi,


 


I am doing drop test analysis, but following error is coming.


 

MESSAGE ID :           44

 

 ** ERROR : ABNORMAL END

      +=============================================================+

      |          Segmentation Violation                             |

      +=============================================================+

      | TRACE BACK :                                                |

      +=============================================================+

      | +  RADIOSS ENGINE                                                                                                                     

      | +   SOLUTION PHASE: Processor=    1/    1                                                                                             

      | +    MAIN LOOP: Cycle=    0                                                                                                           

      | +     INTERNAL FORCES                                                                                                                 

      +=============================================================+

 

 

 

     ERROR TERMINATION

 

could you please suggest to solve this error.

 

 

Thank you 

 

 

Regards,

Narasimahmurthy

Share this post


Link to post
Share on other sites

Hi,


 


to model foams use law70 and tetrahedrons (Ismstr4). It is VERY important to extrapolate the compressive stress-strain-curve near the compression point! If you do not so, the elements will inverse at large deformations finally leading to zero negative.


Share this post


Link to post
Share on other sites

Hi Prakash - I am getting similar problem - 

 

One which listed in this post - 

 

 tried using Icpre=2 with a combination of Ismstr=2, No Isolid; No Ismstr , No Isolid . I also tried Isolid=0,1, But no luck yet.. I am using DT/Brick/CST with 0.6Tscale and 5e-7Tmin

NC= 0 T= 0.0000E+00 DT= 1.2600E-04 ERR= 0.0% DM/M= 0.0000E+00
ANIMATION FILE: similartoes26zsorbothane100kgpvelA001 WRITTEN
-- CONSTANT TIME STEP FOR SOLID ELEMENT NUMBER 16954
-- CONSTANT TIME STEP FOR SOLID ELEMENT NUMBER 17763
-- CONSTANT TIME STEP FOR SOLID ELEMENT NUMBER 11585
-- CONSTANT TIME STEP FOR SOLID ELEMENT NUMBER 13442
-- CONSTANT TIME STEP FOR SOLID ELEMENT NUMBER 16598
-- CONSTANT TIME STEP FOR SOLID ELEMENT NUMBER 16945
-- CONSTANT TIME STEP FOR SOLID ELEMENT NUMBER 17318
MESSAGE ID : 166
** STOP : ZERO OR NEGATIVE VOLUME FOR 3D-ELEMENT ID=18218
MESSAGE ID : 166
** STOP : ZERO OR NEGATIVE VOLUME FOR 3D-ELEMENT ID=18702
ERROR TERMINATION
ERROR TERMINATION

==== End of solver screen output ====

I also tried using Ismstr=1,Icpre=2,No Isolid and it gave me no errors. But the sphere passed through the disk. I got normal termination with this combination. But I don't know if the results are valid/practical?This was the solver output:
NC= 0 T= 0.0000E+00 DT= 1.2600E-04 ERR= 0.0% DM/M= 0.0000E+00
ANIMATION FILE: similartoes26zsorbothane100kgpvelA001 WRITTEN
ANIMATION FILE: similartoes26zsorbothane100kgpvelA002 WRITTEN
ANIMATION FILE: similartoes26zsorbothane100kgpvelA003 WRITTEN
ANIMATION FILE: similartoes26zsorbothane100kgpvelA004 WRITTEN
ANIMATION FILE: similartoes26zsorbothane100kgpvelA005 WRITTEN
ANIMATION FILE: similartoes26zsorbothane100kgpvelA006 WRITTEN
ANIMATION FILE: similartoes26zsorbothane100kgpvelA007 WRITTEN
RESTART FILES: similartoes26zsorbothane100kgpvel_0001_[0001-0001].rst WRITTEN
NORMAL TERMINATION
TOTAL NUMBER OF CYCLES : 170

 

 

 

 

I have tried to use Icpre=2 but problem still persists. Can you please let me know how did you solve this problem ?

Share this post


Link to post
Share on other sites
Guest

Hi,

This NEGATIVE VOLUME error happens when solid elements are very deformed and their characteristic length goes to 0. For large strain formulation the time step of an element goes to 0 when the element is compressed. 

In RADIOSS Starter input file (Runname_0000.rad), use Ismstr =2 in the solid property and  in RADIOSS Engine file (Runname_0001.rad) use the option/DT/BRICK/CST which will set the time step value tmin at which the solid elements will switch to small strain.This means that the solid elements using Ismstr =2 will use large strain formulation while their time step remains greater than tmin, and will then switch to small strain formulation.

(/DT/BRICK/CST option is used to control the time step of the analysis. The time step becomes constant after reaching Tmin specified by the user )

Please try the run with the a higher value of Tmin.

Share this post


Link to post
Share on other sites

Hi George - 

Thank you for your reply. I have already tried doing that. I changed my Ismstr value to 2 and gave tmin value of 7e-7 in control card CST. I am still getting the error. within first 10 mins of run 

Share this post


Link to post
Share on other sites
Hi George
 
Now I am able to run file but I am not getting any h3d file in the end of run. Plus a error message - Inline image 1 
 
pops up when I try to run individual animation file. Am I still missing something ?
 
Thanks

 

Share this post


Link to post
Share on other sites
Guest

Hi,

This seems to be a bug. I'm able to open the same in HyperWorks 14 and 2017 version.

Which version are you using?.

Share this post


Link to post
Share on other sites

Hi - I am using HyperWorks14.0 2017 version. Probably I will try running it again. Can you explain changes/adjustments that made in model ? I know re-defined slave nodes in Self-contact by some other method. Anything other than that ?

  

Share this post


Link to post
Share on other sites
Guest

Hi,

I modified only the contact parameters. 

The recommended contact parameters for /INTER/TYPE7 are:

Istf=4

Igap=2

Fscale_Gap=0.8

INACTI=6

Gap_min=0.1

Fric = 0.1

Iform=2

 

Did you try loading .h3d file?.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...