Jump to content
nppo

import .csv table

Recommended Posts

Hello everyone! I am new so i welcome any help.
I am trying to create a load collector type TABLED1 which I am then going to use in PBUSHT. So what my table actually represents is stiffness over frequency. But instead of entering the values manually, I want to import the values from an excel file. Problem is I don't know the exact format it needs to be in csv/txt file so what I get until know when I import is a table of 2 columns of zeros.

Any help please? Any example maybe?

Thank you in advance

Share this post


Link to post
Share on other sites

Hi,


 


You can import your table using  View:utility tab: tools:Table create.Import option for csv ,txt & .dat is available.


See attached thumbnail.


 


Regards


Rahul R


post-36845-0-43840700-1438076782_thumb.j

Share this post


Link to post
Share on other sites
Guest

HI Nppo,


 


Here is a small screen shot of a single lined XY data.


 


In the image A represents X and B represents Y.


 


Input the X and Y values in the excel sheet and save the same as .csv file.


post-7616-0-74166900-1438077407_thumb.jp

Share this post


Link to post
Share on other sites

Thank you for your answer and I am sorry I wasn't clear. that is what I have been doing but the problem is my .csv file I don't know how it has to be written. For example it looks like:

 

100;17107
101;18008

102;18233

103;18130

103.25;18239

etc...

where 1st value is frequency and 2nd is stiffness, but this format doesn't work.

Share this post


Link to post
Share on other sites

Hi,


 


In which format you are getting the Frequency vs Stiffness data(ASCII, dat etc).Looks like in your csv file you are not getting two columns.one for freq and another one for Stiffness.


Or you are getting any error while running for discontinuty in data points?


 


Regards


Rahul R


Share this post


Link to post
Share on other sites

I had the same issue for .csv import.

The format I had in .csv file was:

100;17107
101;18008

102;18233

103;18130

103.25;18239

etc...

This format lead to the right number of points but with 0 for all cells (same as nppo).

 

I changed it to (replace " ; " by " , "):

100,17107
101,18008

102,18233

103,18130

103.25,18239

etc...

And table import works...

 

May be an issue in Excel parameter for .csv format..

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...