Jump to content
Sign in to follow this  
gopal_rathore

Negative stiffness node error

Recommended Posts

Dear All,

 

I am getting the same error after imposing the constant time step . I have used Type 7  contact in my model.

 

/DT/NODA/CST

 

0.9 3e-5

 

 

 

Initial time step was 1.03 e-07 

 

Thanks

RAM

Share this post


Link to post
Share on other sites

Dear George ,

 

Same error occurs again after changing the STfac to 1 in interface.

 

ROOT: ssc93  RESTART: 0001
 NUMBER OF HMPP PROCESSES     2
 12/07/2016
  **ERROR : NEGATIVE STIFFNESS NODE     1068085
  **ERROR : NEGATIVE STIFFNESS NODE     1068085
 NC=       0 T= 0.0000E+00 DT= 1.0368E-07 ERR=  0.0% DM/M= 8.3687E+01
     ANIMATION FILE: ssc93A001 WRITTEN
     RESTART FILES: ssc93_0001_[0001-0001].rst WRITTEN

                           ** CPU USER TIME **

 #PROC  CONT.SORT  CONT. F   ELEMENT  KIN.COND.  INTEGR.    I/O     TASK0     ASSEMB.   RESOL
   1   .1016E+01 .0000E+00 .1359E+01 .3125E-01 .9375E-01 .1797E+01 .1250E+00 .3125E-01 .2169E+02

                   ** CUMULATIVE CPU TIME SUMMARY **

 CONTACT SORTING............: .1016E+01     4.68 %
 CONTACT FORCES.............: .0000E+00     0.00 %
 ELEMENT FORCES.............: .1359E+01     6.27 %
 KINEMATIC COND.............: .3125E-01     0.14 %

 

 

regards

RAM

Share this post


Link to post
Share on other sites

Dear George,

 

I dont have Type 2 interface in my model.

 

I have Two Type 7 interface in my model.

 

one is self contact and other is contact between model and ground.

 

regards

RAM

Share this post


Link to post
Share on other sites
Guest

Ram,

It is running in HW 14.0 version. Please upgrade your HW version and try running it.

Please clear the penetrations in the model and also impose a fair time step. In the current file mass error is too high and it will terminate the run quickly. So impose a good time step in the model.

 

Share this post


Link to post
Share on other sites

Dear George,

 

Thanks for your support.

 

Fair time step means?

 

Element size in my model is 10mm & 15mm (Majority)

 

Also explain about AMS and how to impose it?

 

Thanks

RAM

 

Share this post


Link to post
Share on other sites
Guest

Ram,

The time step now imposed is much higher and so the mass added is is also higher. Try with a smaller value which will not add too much mass to the model.

 

When you impose /AMS (Advanced Mass Scaling) in the model a non physical mass is added to a structure in order to achieve a larger explicit time step. And so. no mass is actually added to the system while solving. Choose a minimum time step, Tmin, from 10 to 20 times than the one used in /DT/NODA/CST. Tsca used is 0.67 for /AMS.

When /DT/AMS is present in RADIOSS Engine Input, option /AMS is mandatory in RADIOSS Starter Input file

The format for input is     /DT/AMS

                                           Tsca Tmin

In Help Menu, please see the  Example 44- Blow Molding with AMS.

For more info on time step control without compromising the accuracy, please visit the link below:

http://www.altairhyperworks.com/html/en-US/rl/RADIOSS_Simulation_91212.htm

.

Share this post


Link to post
Share on other sites

Dear George,

 

After imposing AMS the model is running fine without any error.

 

I had given   /DT/AMS

Iflag - 1

Tsca - .67

Tmin - 3 e-7

 

Whether there is any standard for calculating the Tmin for AMS.

 

Thanks

RAM

Share this post


Link to post
Share on other sites
Guest

Ram,

There is no standard rule but as a fair practice we can tell,

Any targeted model for AMS application should run first in /DT/NODA/CST with a reasonable energy error and acceptable added mass along its simulation time.Computational convergence and accurate results can be obtained by choosing a minimum time step, Tmin, from 10 to 20 times than the one used in /DT/NODA/CST. 

If the Tmin input is more the AMS job may either fail or diverge, most likely with an error message.

Share this post


Link to post
Share on other sites

Dear George,

 

In my model i have given initial velocity about y axis , but in the result in hyperview it shows zero.

 

since gravity also comes into the account ,it is difficult to find whether the solver took the velocity or not.  

 

How can we check whether the solver takes that initial velocity or not?

 

Thanks

RAM

 

ner.png

Share this post


Link to post
Share on other sites
Guest

Ram,

I dont think we have such an option available. But the solver will take the loads applied by the user, if there are no kinematic constraints.

Share this post


Link to post
Share on other sites

Dear George ,

 

I have recreated the initial velocity about an axis but the solver is not taking the velocity which i had applied .

 

In results it shows zero value.

 

Kindly provide your guidelines 

 

Thanks

RAM

Share this post


Link to post
Share on other sites
Guest

Ram,

Ensure you have applied the loads correctly to the model. If any rigid bodies are there, ensure the load is applied in the master node also.

Make sure that the kinematic constraints also does not violate the loads applied.

Share this post


Link to post
Share on other sites

Dear George,

 

I have checked the model and recreated the initial velocity but can't able to identify the error.please check my model which i had shared in your dropbox and let me know the error .

 

Thanks

RAM

Share this post


Link to post
Share on other sites
Guest

Dear Ram,

Make IDROT=1 in /IOFLAG and try running the analysis.Please check the results then.

Analysis>>Control Cards>>IOFlagCard

Capture2.JPG

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...