Jump to content
Emad

network license on a linux cluster

Recommended Posts

Hello,

 

I've installed HyperWorks on our Linux-Cluster (SUSE Linux Enterprise Server 11 SP3). But I was not able to configure the license of the program.

We are using a network-license and thus I set the environment variable to our host address (with export ALTAIR_LICENSE_PATH=...). But as I run HyperGraph I get an error (see the attachment). It seems that HyperWork is still trying to use a local license.

Therefore I've also installed the "licensing12.2" on the cluster but I think it needs something else. Can anyone help me to configure the licensing on linux?

I thank you in advance.

 

Regards

Emad

 

 

Unbenannt.PNG

Share this post


Link to post
Share on other sites
Guest

Hi,

 

Can you place the license file in Licensing12.2 folder?

 

Open the Altair-serv.cfg file in a textpad and search for the line "License_File" equals to the path of the license as shown in the image.

 

At the end restart the license server and try again.

 

 

Capture.JPG

Share this post


Link to post
Share on other sites
12 hours ago, Q.NGUYEN-DAI said:

Do you setup a License server? What's exact value of variable  ALTAIR_LICENSE_PATH  ?

The path is 6200@license, where the license is an intern server which is accessible from the cluster (checked with ping)

I set up the license on another server and now want to call it from the cluster.

Share this post


Link to post
Share on other sites
4 hours ago, Prakash Pagadala said:

Hi,

 

Can you place the license file in Licensing12.2 folder?

 

Open the Altair-serv.cfg file in a textpad and search for the line "License_File" equals to the path of the license as shown in the image.

 

At the end restart the license server and try again.

 

 

Capture.JPG

 

I don't have a license file on the cluster. I have to call it from another license-server. But in the "Altair-serv.cfg" there is no possibility to enter the license-path as a network address.

Share this post


Link to post
Share on other sites
Guest

Hi Emad,

 

Make sure the license file is placed in Licensing folder and not in security folder of HyperWorks installation.

 

Is the license manager running? can you confirm this?

Share this post


Link to post
Share on other sites
Guest
3 hours ago, Prakash Pagadala said:

Hi Emad,

 

Make sure the license file is placed in Licensing folder and not in security folder of HyperWorks installation.

 

Is the license manager running? can you confirm this?

 

For a License server setup, the license file could be anywhere on server! Just define the correct fullpath in altair-serv.cfg file.

 

Share this post


Link to post
Share on other sites
Guest
4 hours ago, Emad said:

The path is 6200@license, where the license is an intern server which is accessible from the cluster (checked with ping)

I set up the license on another server and now want to call it from the cluster.

 

Check if your server is running by using the following command:

 

# /opt/altair/licensing12.2/bin/lmxendutil -licstat -host yourLicServName

My server was installed within /opt/altair/licensing12.2

 

Share this post


Link to post
Share on other sites

Hi,

Sorry that it was a bit confusing. Maybe I should explain it again :)

 

I installed HyperWorks 13.0. If I enter the following command:

 /home/programme/HyperWorks/13.0/altair/security/bin/linux64/lmxendutil -licstat -host MyLicServName -port 6200 -network

It gives me a list of available licenses (everything ok).

But If I enter:

/home/programme/HyperWorks/13.0/altair/security/bin/linux64/lmxendutil -licstat
It gives me an error that it cannot find any licenses under 6200@master (master is the name of my cluster-machine).

And when I run the hg from /home/programme/HyperWorks/13.0/altair/scripts/ it gives me an error (see attachment)

 

I also installed a licensing12.2

There, if I enter the following command:

/home/programme/HyperWorks/licensing12.2/bin/lmxendutil -licstat -host MyLicServName -port 6200 -network

It gives me a list of available licenses (everything ok).

And If I enter:
/home/programme/HyperWorks/licensing12.2/bin/lmxendutil -licstat

It gives me again an error that it cannot find any license under 6200@master (master is the name of my cluster-machine).


I appreciate your time and effort for helping me. Thanks!

 

Unbenannt_2.PNG

Share this post


Link to post
Share on other sites
Guest

So the host "MyLicServName" (within your command line) and "master" (define with 6200@....) are two different hosts ?

To use License server, from client side, you have to define :

export ALTAIR_LICENSE_PATH=6200@YourLicServ

I don't understant where comme from your "6200@master" ????

Share this post


Link to post
Share on other sites

I've already defined the host with

export ALTAIR_LICENSE_PATH=6200@YourLicServ

I tried to find it out (with grep), where does this 6200@master come from. But it is not defined in any configuration file!

Share this post


Link to post
Share on other sites
Guest

Emad,

 

Can you check if there are any license files on your (cluster) machine?

 

also, can you share the altair-serv.cfg file and .bashrc file?

 

Looks like this is an issue with the environment variable.

Share this post


Link to post
Share on other sites

Hi Prakash and Nguyen,

 

thanks a lot for your helps. I found the problem.

It was indeed because of the environment variable. It seems that "export" does not set the environment-variable permanently and it will disappear after a terminal restart! I added the environment variable to /etc/environment and restarted the machine. Now it works.

 

Thanks again

Emad

Rahul Ponginan likes this

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...