Jump to content
Vincent

Topology optimization on a turbofan engine fan blae

Recommended Posts

Hello, I am a new user to hyperworks, I am a student and currently doing a project on topology optimization on an engine fan blade, I have gone through the tutorials and built up my model, but I have some problems to create the results of topology optmization, basicly my model has two structures, one external structure (Non-design) and one internal structure(design) and they are meshed seperately, I am trying to optimize the internal strucure while under centrifugal load and aerodynamic load, therefore I set the external structure as the constraint, and applied aerodynamic load and centrifugal load on the structure,  I received an error message when I was creating the result, can anyone help me check what is the problem? The message is :" Invalid design problem. All the sensitivities of response 1 (objective) are zero." I have attached my model file, please help me take a look which part is incorrect to get the result. Thanks a lot.

fan-blade-project.hm

Share this post


Link to post
Share on other sites
On 17/03/2016 at 5:06 AM, Vincent said:

Hello, I am a new user to hyperworks, I am a student and currently doing a project on topology optimization on an engine fan blade, I have gone through the tutorials and built up my model, but I have some problems to create the results of topology optmization, basicly my model has two structures, one external structure (Non-design) and one internal structure(design) and they are meshed seperately, I am trying to optimize the internal strucure while under centrifugal load and aerodynamic load, therefore I set the external structure as the constraint, and applied aerodynamic load and centrifugal load on the structure,  I received an error message when I was creating the result, can anyone help me check what is the problem? The message is :" Invalid design problem. All the sensitivities of response 1 (objective) are zero." I have attached my model file, please help me take a look which part is incorrect to get the result. Thanks a lot.

fan-blade-project.hm

 

 

Hi there. I will be doing a similar project soon. Do you mind sharing with me where you got the tutorials to build the model fan?

Share this post


Link to post
Share on other sites
On 3/17/2016 at 2:36 AM, Vincent said:

Hello, I am a new user to hyperworks, I am a student and currently doing a project on topology optimization on an engine fan blade, I have gone through the tutorials and built up my model, but I have some problems to create the results of topology optmization, basicly my model has two structures, one external structure (Non-design) and one internal structure(design) and they are meshed seperately, I am trying to optimize the internal strucure while under centrifugal load and aerodynamic load, therefore I set the external structure as the constraint, and applied aerodynamic load and centrifugal load on the structure,  I received an error message when I was creating the result, can anyone help me check what is the problem? The message is :" Invalid design problem. All the sensitivities of response 1 (objective) are zero." I have attached my model file, please help me take a look which part is incorrect to get the result. Thanks a lot.

fan-blade-project.hm

Hi,

First make sure that you have proper connectivity between external and internal mesh.I checked your hm file and mesh seems to me not connected.

 

Regards

Rahul R 

Share this post


Link to post
Share on other sites

×
×
  • Create New...