Jump to content
Ognox

How to re-analyze model with problematic mesh after OSSmooth?

Recommended Posts

I have used OSSmooth command for my found topology but it seems impossible to re-run the analysis as it contains so many meshing errors. My element quality check identifies 4795 free edges. I tried re-meshing the whole volume and re-assign my design/non-design space but it didn't help. Is there any solution for this matter?

 

Optimization.hm

Share this post


Link to post
Share on other sites
Guest

I would extract the surface/stl and modify the geom in any CAD tool, mesh again with quality and analyze.

Share this post


Link to post
Share on other sites

I extract the surface (Tools->faces->find faces) and mesh it again (3D->tetramesh->mesh) and it says "...30 volumes meshed". I then try to assign the material property but it seems that part of my generated elements are of the invalid type (I tried changing the type too). Analysis check then gives a message: "No PSHELL properties exist in the bulk data"

 

I tried exporting it as .stl getting a prompt to save invalid elements to user remark and the software can't read the file afterwards.

 

I've gone through the tutorials and it seems very tedious in this case. I think I should somehow smoothen out the geometry. Any detailed advice on how to fix the geometry in Hypermesh? 

 

Capture1.PNG

 

Capture2.PNG

Share this post


Link to post
Share on other sites
Guest

You are assigning Shell property to 3D elements which is wrong.

 

Asign PSOLID property instead.

Share this post


Link to post
Share on other sites

I have managed to save topology geometry as .stl, I opened it up and meshed it with tetramesh. I got no errors and successfully assigned material properties. However, my analysis check gives:

Element # 77181, element type TETRA.
 *** PROGRAM STOPPED: ERRORS DURING ELEMENT QUALITY CHECK.

 

Optimization1.fem

 

I didn't get any errors while meshing but it seems that I may still have some free edges. What am I missing?

Share this post


Link to post
Share on other sites
Guest

You can turn off element check, or remesh with quality.

 

To turn off element check, goto Control cards> Param>>ELCHECK >> NO

Share this post


Link to post
Share on other sites
7 hours ago, Prakash Pagadala said:

You are assigning Shell property to 3D elements which is wrong.

 

Asign PSOLID property instead.

 

I am not assigning shell elements, check the properties of the previously attached file. CHECKEL seemed to help though but when I run analysis I get 0 displacement. Maybe this is related to several volumes generated by my tetramesh :(

May I ask you to have a look at this?

Optimization3.hm

Share this post


Link to post
Share on other sites

Why dont you try Solidthinking Inspire?Latest polynurb tool is fantastic to generate smooth geometry from optimized part.

If interested please share CAD file to me.I will try & share you steps to do.

Please refer video in below link.after 6 mint polynurb topic & demo is available.

http://web.solidthinking.com/inspire_2016_intro?_ga=1.230735194.439823479.1465444733

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...