Jump to content
Sign in to follow this  
VisSim Forum Archives

TransferFunction Block

Recommended Posts

Submitted by ctedie on Wed, 07/27/2011 - 20:47 

Hi,
I have troubles to use the Transfert function block with a TMS320F28035.
I try to filter a signal with a low-pass filter.
It runs good in simulation mode, but when I compile the block and then run the vissim diagram of my compilated block I have nothing in the filtered output.
Could you help me?
I join the diagram I use

Filtrage.vsm

Filtrage-Simu.vsm

Share this post


Link to post
Share on other sites

Submitted by Anders89 on Fri, 07/29/2011 - 00:17.

Because your cutoff frequency is 5 orders of magnitude lower than the sampling frequency there are some small values in the coefficients. This requires use of 32-bit precision in the fixed point filter (you were using 16-bit). Here is an example of a run showing good agreement between 

 

slowFilterOutputCompare.png

 

simulation on the PC and results from the embedded target. Please find the modified diagram attached below.

Filtrage2.vsm

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...