Jump to content
zack

unusual issue by running HW and License Problem

Recommended Posts

Hello all,

 

at first sorry for my poor englich.

 

i downloaded HW14.0 Student- Edition to run motionview and motionsolve, also ich got a node locked license for Student Edition.  i installed HW14.0 Stu-Edition successfully and placed it in the security folder within the installation folder. everything is ok.

 

Then i ran HW14, it came a application problem

 

3.jpg

 

 

Details

list element in quotes followed by "nur" instead of space
list element in quotes followed by "nur" instead of space
    while executing
"llength $pairs"
    (procedure "::msgcat::mcmset" line 4)
    invoked from within
"::msgcat::mcmset de {
        "Rigid Body on Lines"                     "Starrkörper auf Linien"
        "Rigid Body on Surfaces"                  "S..."
    (in namespace eval "::b3d" script line 205)
    invoked from within
"namespace eval ::b3d {
    ::msgcat::mcmset de {
        "Dimension Mode"                          "Vermessungsmodus"
        "Material Database"     ..."
    (file "F:/Software/Altair/14.0-edu/hm/scripts/BasicFEA/languages/de.msg" line 2)
    invoked from within
"::source -encoding utf-8 F:/Software/Altair/14.0-edu/hm/scripts/BasicFEA/languages/de.msg"
    ("uplevel" body line 1)
    invoked from within
"uplevel 1

  1. "
        (procedure "::msgcat::mcload" line 10)
        invoked from within
    "::msgcat::mcload $msg_directory"
        (procedure "::b3d::L10n::SetLocale" line 14)
        invoked from within
    "::b3d::L10n::SetLocale """
        (in namespace eval "::" script line 4)
        invoked from within
    "# Compiled -- no source code available
    error "called a copy of a compiled script""
        invoked from within
    "tbcload::bceval {
    TclPro ByteCode 2 0 1.7 8.5
    14 0 132 24 2 0 84 1 4 14 14 -1 -1
    132
    f!!!!#-<<!+f+pv+K&s!*V!S7&-<<!)9N<!3fAs!5v!!!C!!!!gF#!!)`vpv1l8X!..."
        (file "F:/Software/Altair/14.0-edu/hm/scripts/BasicFEA/main.tbc" line 14)
        invoked from within
    "source $rootname.tbc"
        (in namespace eval "::UserProfiles::BasicFEA" script line 7)
        invoked from within
    "# Compiled -- no source code available
    error "called a copy of a compiled script""
        (procedure "::hwt::SourceFile" line 1)
        invoked from within
    "::hwt::SourceFile $path3/BasicFEA/main.tcl"
        (procedure "::UserProfiles::BasicFEA::PanelProc" line 47)
        invoked from within
    "::UserProfiles::BasicFEA::PanelProc"

 

 

then i click OK and chose die Motionview-icon,  however i find that Motionview and Motionsolve can run perfect. i have tried many times wenn i run HW in a month, this issue occurred  everytime. because i can run Motionview and Motionsolve so i forget it and let it

 

These days i learn co-simulation using simulink and motionsolve, i want to use a xml file that i can put it into simulink-S funktion. so at first i run a simulation with my own model and generate a xml file. then i try to run it by motionsolve,like tutorial MV 7002.  unfortunately, it occurred another issue 

 

 

1.jpg

2.jpg

 

 

so i dont unterstand what is happend, accualy before this happend, i have puted some xml files into simulink-S funktion but simulink always can`t run a cosimulation because of a error" input xml file is not accessible", through i have set environment variable and matlab path. so i guess ,this licence issue is a big unusual problem against my cosimulation-work using simulink and run xml file using motionsolve

 

 

today i have read  basic licence troubleshooting and used the command to get my physical adress, i use a pc with system Win10 64bit 

 

C:\Users\Kan>ipconfig/all

Windows-IP-Konfiguration

   Hostname  . . . . . . . . . . . . : Zack
   Primäres DNS-Suffix . . . . . . . :
   Knotentyp . . . . . . . . . . . . : Hybrid
   IP-Routing aktiviert  . . . . . . : Nein
   WINS-Proxy aktiviert  . . . . . . : Nein

 

 

Ethernet-Adapter LAN-Verbindung:

   Verbindungsspezifisches DNS-Suffix:
   Beschreibung. . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physische Adresse . . . . . . . . : 00-08-02-E6-1D-FC
   DHCP aktiviert. . . . . . . . . . : Ja
   Autokonfiguration aktiviert . . . : Ja
   IPv6-Adresse. . . . . . . . . . . : 2a02:908:4e0:fda0:208:2ff:fee6:1dfc(Bevorzugt)
   Lease erhalten. . . . . . . . . . : Donnerstag, 28. Juli 2016 23:20:25
   Lease läuft ab. . . . . . . . . . : Freitag, 29. Juli 2016 00:24:25
   IPv6-Adresse. . . . . . . . . . . : 2a02:908:4e0:fda0:757d:9711:dfdf:ca51(Bevorzugt)
   Temporäre IPv6-Adresse. . . . . . : 2a02:908:4e0:fda0:bcb6:a5ab:c610:414a(Bevorzugt)
   Verbindungslokale IPv6-Adresse  . : fe80::757d:9711:dfdf:ca51%5(Bevorzugt)
   IPv4-Adresse  . . . . . . . . . . : 192.168.0.14(Bevorzugt)
   Subnetzmaske  . . . . . . . . . . : 255.255.255.0
   Lease erhalten. . . . . . . . . . : Donnerstag, 28. Juli 2016 23:20:25
   Lease läuft ab. . . . . . . . . . : Freitag, 29. Juli 2016 23:20:23
   Standardgateway . . . . . . . . . : fe80::ce35:40ff:fe29:e1a3%5
                                       192.168.0.1
   DHCP-Server . . . . . . . . . . . : 192.168.0.1
   DHCPv6-IAID . . . . . . . . . . . : 234890269
   DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-18-3B-88-50-00-08-02-E6-1D-FC
   DNS-Server  . . . . . . . . . . . : 2a02:908:2:a::1
                                       2a02:908:2:b::1
                                       192.168.0.1
                                       192.168.0.2
   NetBIOS über TCP/IP . . . . . . . : Aktiviert

 

 

Tunneladapter isatap.{523E55D6-2B14-4E33-A44F-D62361A67184}:

   Medienstatus. . . . . . . . . . . : Medium getrennt
   Verbindungsspezifisches DNS-Suffix:
   Beschreibung. . . . . . . . . . . : Microsoft ISATAP Adapter
   Physische Adresse . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP aktiviert. . . . . . . . . . : Nein
   Autokonfiguration aktiviert . . . : Ja

 

Tunneladapter LAN-Verbindung* 2:

   Verbindungsspezifisches DNS-Suffix:
   Beschreibung. . . . . . . . . . . : Microsoft Teredo Tunneling Adapter
   Physische Adresse . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP aktiviert. . . . . . . . . . : Nein
   Autokonfiguration aktiviert . . . : Ja
   IPv6-Adresse. . . . . . . . . . . : 2001:0:5ef5:79fb:ce7:a7a:dae7:63be(Bevorzugt)
   Verbindungslokale IPv6-Adresse  . : fe80::ce7:a7a:dae7:63be%6(Bevorzugt)
   Standardgateway . . . . . . . . . :
   DHCPv6-IAID . . . . . . . . . . . : 100663296
   DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-18-3B-88-50-00-08-02-E6-1D-FC
   NetBIOS über TCP/IP . . . . . . . : Deaktiviert

 

C:\Users\Kan>getmac

Physisch. Adresse   Transportname
=================== ==========================================================
00-08-02-E6-1D-FC   Nicht zutreffend

 

 

 here the licence info

 

4.jpg

 

 

so i find that licence is ok, version=14 and ETHERNET 000802E61DFC are also OK..but the MAC adress is "not applicable" (german:nicht zutreffend) by using getmac 

 

who can tell me, what can i do to fix these, i need your help....

 

thank you

Share this post


Link to post
Share on other sites

Hello,

 

the first issue is related to starting HyperWorks with the BASIC FEA User Profile. This will lead to the error message as you deacribed. To avoid, please select a different User Profile (e.g. OptiStruct) and then close and restart the HyperWorks Student Edition.

 

The second error is a license error, probably due to the fact that the HyperWorks Student Edition does not support Co-Simulation with Simulink yet. You would need to use the full license of your university and a full installation of HyperWorks 14 to run the Co-Simulation. Please contact your university advisor or us in order to get access to a full license of HyperWorks.

 

Jan

Share this post


Link to post
Share on other sites
On 17.8.2016 at 9:32 AM, Jan Grasmannsdorf said:

Hello,

 

the first issue is related to starting HyperWorks with the BASIC FEA User Profile. This will lead to the error message as you deacribed. To avoid, please select a different User Profile (e.g. OptiStruct) and then close and restart the HyperWorks Student Edition.

 

The second error is a license error, probably due to the fact that the HyperWorks Student Edition does not support Co-Simulation with Simulink yet. You would need to use the full license of your university and a full installation of HyperWorks 14 to run the Co-Simulation. Please contact your university advisor or us in order to get access to a full license of HyperWorks.

 

Jan

Thank you Jan

 

I have used the full license to run HW14.0 in my uni with MV7002-Cosimulation with Simulink. But the save error appeared everytime..

 

 

See hier 

 

i have added the xml full path..but it didn't help

 

have you any idee? thanks a lot!

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...