Jump to content
nextdc

IsoSurface.Value error

Recommended Posts

Hi AltairHW

 

I'm using FEKO 14.410 EDU edition and experimenting with the script example https://www.feko.info/support/lua-scripts/radiation-hazard-iso-surfaces/radiation-hazard-iso-surfaces-wizard

 

When running this code I receive an error when setting p1.IsoSurface.Value = 41

"POSTFEKO 14.0.410-277905 (x64)
c:\Development\Workspace\win64_Maintenance\utilities\geometry\include\common_RangeOf.hxx (41): Assertion failed: !isEmpty() "

 

If I comment out this line the script completes without error.

I can't determine why p1 is failing to set the value.

What is strange is p2 is a duplicate of p1 and it will set p2 value without error.

 

 

p1 = app.Views:Item(views+1).Plots:Add(scaledNearField)             
p1.Visible = false
p1.PlotType = "Iso-surface"
p1.Legend.Position = "None"                                    
p1.Label = ("RMS_Public" .. append_to_label)
p1.Visualisation.Opacity = 40                        
p2 = p1:Duplicate()                               
p2.Label = ("RMS_Occupational" .. append_to_label)
p2.Visualisation.Opacity = 40

 

-- ERROR OCCURS HERE WHEN SETTING p1's isosurface value

-- If I comment out this line the script completes without error

-- note that p2 successfully sets the value without error!?

p1.IsoSurface.Value = 41

 

p1.Visible = true

 

-- p2 is a duplicate of p1

-- can set p2 value without error

p2.IsoSurface.Value = 92
p2.Visible = true

 

regards

David

 

 

Share this post


Link to post
Share on other sites

Hi David

 

I see that you are able to set the iso-surface value for p2 to 92, but that the error is given when setting the value for p1 to 41. Is this correct?

 

If so, it is possible that a value of 41 is outside your data range. Iso-surfaces can only be defined for data within the available range.

 

Regards,

Johan

Rahul R likes this

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...