Jump to content
huijaek

import IGES into hypermesh and make as solid

Recommended Posts

Hi


 


I am trying to import IGES and make as solid.


 


After I imported the geometry,


 


    Geometry tab -> solids-> Go to model tab -> right click components -> make current


    Under solids -> Surfs-> by collector-> select component -> create


 


I followed procedure above and when I used v11, the procedure worked well, but now I use v12 and it does not work anymore.


 


Is there any other way to make geometry as solid in v12 or should I modify any settings for the recently installed hypermesh?


 


I would appreciate any help.


 


Thanks,


 


Jay


 


Share this post


Link to post
Share on other sites
Guest

In HW12.0, to create solid from bounding surfaces, go to : geoms => solids => see image below :


 


 9323598113_be8fd02250_o.png


Share this post


Link to post
Share on other sites

Hi
 
Actually I don't fully understand your explanation, and I tried but I got light-blue-edges.
 
What does the light blue edge mean?
 
And I still cannot make it as solid.
 
I did : geom => solids => click surfs => choose by collector => check components => select => create
 
Error message said 'No closed volume found".
 
I tried to attach IGES file, but I am not permitted to upload that kind of file.

 

Do you have any ideas why I cannot create solid?

 
I would appreciate any help.
 
Thanks,
 
Jay

Share this post


Link to post
Share on other sites
Guest

Hi,


 


Q.NGUYEN-DAI means the geometry color mode. Switch to "By 2D Topo" (from "Auto") and check if there are any red lines as geometry border.


Go into the visualization option and switch all other types off (green, yellow and light blue = supressed edges, as you asked).


 


The message 'No closed volume found" means exactly what it says. Your surfaces doen't form a closed area (made by green or blue edges)


 


Regards,


Mario

Share this post


Link to post
Share on other sites

I am having the same error "no closed volume found" when trying to create solids from surfaces, but I have all green, shared, edges. I imported an IGES file from SolidWorks. I'm also using v12. Is there something else I should check?


 


Thanks!


Share this post


Link to post
Share on other sites

I think usually this happen when you have unconnected elements/nodes. Did you check whether you have free edges? 


 


Try to go to Tools > edges > click on displayed elements > find free edges / T-connection.


 


If you have free edges, edit them so they are well connected.


 


Best,


Mushi


Share this post


Link to post
Share on other sites

while importing ur IGES, open import options and make sure that it is Automatic in Cleanup tolerance (as shown in pic)... and also don't pick you surfaces by clicking "displayed" or "all" just select your surfaces by clicking on it individually.

post-29217-8610_thumb.png

Share this post


Link to post
Share on other sites

I have a red lines, but I can't eliminate this lines. I'm trying with Toggle.

 

Hi Jardel,

 

In the toggle option, just increase the tolerance value and try again..

(Here, Tolerance value defines the maximum distance between the edges)

Share this post


Link to post
Share on other sites

Hi,


I was struggling with this issue too and getting the error "No Closed Volume Found".  I talked to support and my issue was that HM 12.0 and 13.0 imports the .igs file as a solid and surfaces.  I think that HM 11.0 only imported the .igs file as surfaces or there was something else different in 11.0 with the import.  I deleted the solids so that only the surfaces remained and then I was able to work with the geometry and create a solid between two surfaces.  To check what geometry you have, you can select 2D topo or 3D topo but just remember the colors are flipped (in 2D topo, green is a surface and blue is a solid while in 3D topo, green is a solid and blue is a surface).


 


Cheers,


Hannah


Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...