Jump to content
Loesje84

Start Hyperview in batch mode

Recommended Posts

Dear all,

 

I have written some macro's in TCL that use hyperview in batch mode. It runs fine on my machine, but my collegues get the error

"Failed to load package hwt couldn't read file "c:/altair/14.0/hw/tcl/hwt/pkgIndex.tc" no such file or directory while executing "source {c:/altair/14.0/hw/tcl/hwt/pkgIndex.tcl}"

What I did:

I opened the tclsh85.tcl and typed in

exec c:/altair/14.0/hw/bin/win64/hw.exe -b -tcl c:/user/test/tcl

in which test.tcl contains "puts hello"

When I run the same syntax (without exec) in cmd.exe it works, but as my progs are written in TCL, it's no use using cmd. 

I tried to add the hwt dir to the altair environment variable, added the path to auto_path, and I also ran source {c:/altair/14.0/hw/tcl/hwt/pkgIndex.tcl}  in the tclshell, but it all didn't help.

Package names shows on all computers the exact same list, either in the tchshell or in Hyperview.

What could be different? By the way: if some of my collegues log in into my computer they also get this error, except 1 collegue: if he logs in on my computer it does work. If I, on the other hand, log in to their computer, I get the failed to load package error.

 

Who can help me?

 

Kind regards,

Loesje84

Share this post


Link to post
Share on other sites

Thank you for your response, but I already know the syntax, which is working perfectly on my machine. The problem is that when I want to run Hyperview in batchmode using TCL (so, with option -b) on the machines of my colleagues, they get the above mentioned error. Anyone else any idea how to solve it? We have Windows 7, 64bit computers by the way.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...