Jump to content
Sign in to follow this  
yao

Why do I get 'The specified address is already in use' or 'The requested port number is already in use'?

Recommended Posts

By default when acuFieldView (or FieldView) is launched it tries to make a connection for client/server behavior. The default client port number that is used is 12345. If something else is using that port number, then you will see that error.

Let's assume that on a Linux system, AcuSolve is installed in /home/Acusim/LINUX64/V1.7f/... There are two ways around this - both involving settings in one of the Acusim.cnf files.

1. This will disable client/server mode for acuFieldView: 
acufieldview_executable = /home/Acusim/LINUX64/V1.7f/bin/acuFv -port none

2. This will use a different port number from the default: 
acufieldview_executable = /home/Acusim/LINUX64/V1.7f/bin/acuFv -port 12344 
NOTE - It is good if each user uses a different port number if they are all working on the same machine.

You can see the default setting for acufieldview_executable via 
'acuConsole -h'

It is also possible that a firewall is blocking access to that default port 12345.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...