Jump to content

Recommended Posts

Hello,

 

I am trying to do a topology optimization over a subframe piece. In order to do that, I minimize the volume with respect to all the load cases.

 

As of right now, I am trying to add a natural frequency constraint to my problem. To do that I followed the tutorial:

OS-2020: Increasing Natural Frequencies of an Automotive Splash Shield with Ribs

 

However, by strictly applying that tutorial, I encounter the following error:

*** ERROR # 5617 ***
 The SUBCASE ID in ATT1 field of DRESP1 1 does not refer to a modal FRF subcase.

 

From what I understand from it, it is due to the loadstep defined during the creation of the response (Not appearing in the tutorial, maybe due to an update?). By suppressing the link to a loadstep by editing the response, the optimizer runs fine. However, I am not sure it took my constraint well into account.

 

Thanks in advance for your help.

Regards,

 

Adrien

Share this post


Link to post
Share on other sites
Guest

Hi @Taranis

 

What is your objective for optimization and what is the type of analysis you are doing?

 

It would be better if you share the model file with us or atleast .out file. 

 

 

Share this post


Link to post
Share on other sites

Hello Prakash,

 

How can I do that ? Is it an option available within hypermesh or should I download this version (And where to download it) ?

 

Thanks again for your help.

 

PS: My technique seems to work so it is mainly to compare the results.

 

Adrien

Share this post


Link to post
Share on other sites

Hello,

 

has the bug been removed, yet? I am asking because I have the exact same problem and, just like Taranis, I suppressed the link to the load step and the solver doesn't show an error message anymore. 

However, I don't really trust my results... Hence, I would like to make sure that this workaround really works.

 

In my case, I would like to optimise a part with the objective to achieve the minimal volume, but as an additional constraint, I would like to add that the natural frequency of the optimised part should not be lower than 100 Hz. Is setting up a modal analysis and then setting the frequency to min 100 as a dconstraint the right way to do this? Is there another way?

 

Thanks for your answers!

Share this post


Link to post
Share on other sites
Just now, Prakash Pagadala said:

@Kensei,

 

The issue is fixed in 2017.2 which will be available soon. 

 

 

But until the workaround is fine? 

Concerning my other question... can I add the natural frequency constraint like this?

Share this post


Link to post
Share on other sites

Hello,

I have come across the same bug, while going through OS-3200 Tutorial.
It seems, however, that the bug is still there, even after installing the latest HW components, see  the list below:

 

Updates Information:
------------------------------------------------------------
hwDesktop2017.2
hwDesktop2017.2.1_hotfix
hwSolvers2017.2
hwSolvers2017.2.1_hotfix

 

What can I do about it? Is the problem at the HM translation side (which could somehow be fixed by hand-editing the .fem), or at the side of the solver?

 

Regards

Marek Augustyniak

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...