Jump to content
Sign in to follow this  
mavijay

Enforced Displacement

Recommended Posts

Hi guys good morning

 

I have attached two solver deck which has similar set up similar elements count almost same except updated stress strain curve and small design changes.

 

For the first deck the analysis time is very less when compared to the other which is running for days.

 

Can someone guide me regarding this so that I can be able to fix it.

 

Thanks in advance

 

 

 

Share this post


Link to post
Share on other sites
Guest

Hi,

Due to time step drop the simulation was taking more to run. From the starter out file we can see that the model is having very low time step.

This can be due to an element, a node or an interface.

•For an element, check the related material (especially its Young modulus and density in case of an elastic-plastic material; and its viscosity in case of a visco-elastic material). There must not be an error in the units system that this data is given in.

Check the size of the element, since elemental length is proportional to time step.

•For a node, check the characteristics of connected elements. If the node is on the master side or the slave side of an interface, this interface must be verified.

•For an interface, the gap of the interface must be verified if some failure happens on the master or the slave side of the interface.

Once this is cleared you can run the simulation without time step being dropped.

In this case, it is due to an element, which can be monitored from the engine out (_0001.out) file.

I have imposed a time step in this model in order to control the time step and the run has completed. The mass error generated in this case is also very less.

Please watch this webinar which explains about time step control: http://www.altairuniversity.com/learning-library/considerations-about-time-step/

The model file is attached along.

 

 

 

Share this post


Link to post
Share on other sites

Hi George P Jhonson.

 

Thank you very much for your fast reply and sharing the file. You guys are really helpful. Thank for the useful information which you shared.

 

 

Share this post


Link to post
Share on other sites

Hi George

 

When I'm trying to run the analysis for a similar kind of set up with slight design changes, the analysis is not running till the end it throws up some error as I attached below.

I tried to increase the Gap-min but still the error exists any suggestion or any changes. I have also attached the new design file for your reference.

 

 

 

Thanks in advance

 

 

Share this post


Link to post
Share on other sites

Hi George

 

Thanks for the help It is working just fine..

 

Is it possible to calculate the pulling force in Z-direction with this results by creating output block reaction force like REACX REACY REACZ?

 

Thanks in advance

Share this post


Link to post
Share on other sites
Guest

Hi,

You can create an output block for the rigid body node and can plot the reaction forces in the required direction.

 

Share this post


Link to post
Share on other sites

Hi George

 

It worked thanks again.

 

I have attached the deck with the hyper graph

 

For the calculation of removal force I know that I  have to choose a peak value close to the release. I also need to look at animation H3D file as well to get the corresponding time of exact removal  to get the value.

 

My question is about the unit systems can you please refer to my file and let me know my removal force with units if possible and can you also tell me that my analysis is correct or not?

 

graph.mvw

 

 

 

Share this post


Link to post
Share on other sites
Guest

Hi Vijay,

The simulation looks fine and all the parameters are fine.

For a better plot, that is in order to reduce the dynamic effect in the plot, you can reduce the time history (/TFILE) plot frequency (like 1e-3).  For the release force of the rod you can create an output block for the rigid body and can plot the time history for the resultant force (TF). We cannot assess the release force for a single point in this simulation, instead the plot is enough.

I think the unit system followed is kg, m, second. Please find the attached consistent unit system followed so that you can find the units for every output.

UNIT CONSISTENCY.png

Share this post


Link to post
Share on other sites

Hi George

Finally done with the clip

 

I have attached a running board linear static analysis.

I’m getting a deflection of about 0.0053mm deflection. But in real scenario they are experiencing 1 to 5mm deflection.

Instead of applying load on REB3 if I applied load as a point load (single point in the middle of 200 x 80 mm) I’m getting deflection of 3mm.

So what should I do here? Should I use REB3 or point load for a cross section of 200 X 80 mm

 

 

Share this post


Link to post
Share on other sites
Guest

Hi Vijay,

This query has been moved to OptiStruct forum and our OptiStruct expert will guide you to solve this. You can follow up the query from : http://forum.altairhyperworks.com/index.php?/topic/20152-linear-static-analysis/

 

 

PS:As this is a public forum I recommend you not to attach any confidential model files here. You can send us the model files through the secure dropbox link. 

Share this post


Link to post
Share on other sites
Guest

Hi Vijay,

The load seems to act in the intended direction, as the imposed displacement is defined with a local skew.

Moreover, in the boundary condition applied (ref node bc) it sees like an incompatible kinematic condition as the Y direction is locked. Please recheck the same

Capture.PNG

Share this post


Link to post
Share on other sites
Guest

Hi Vijay,

While applying imposed displacement select all the nodes of these three components, including rigid body master node and try running the analysis.

Share this post


Link to post
Share on other sites
Guest

Hi VIjay,

Please redefine this interface (interface id-1)..Instead of contact surface for master select components and select sheet metal 2 as master and node set of rubber as slave, with a Gapmin of .0025, Istf=4, and run the analysis. And I think between rubber and tape components Type 2 interface may be better. Please try with the same.

Share this post


Link to post
Share on other sites
Guest

Hi Vijay,

Please recheck the unit system followed in your model. I think the unit consistency is wrong.

Please modify the units accordingly with this consistency shown. 

Regarding the contact issue, for the sheet metal part constrain only the end nodes of the component instead of constraining all the nodes and try running. 

UNIT CONSISTENCY.png

Capture.PNG

Share this post


Link to post
Share on other sites

Hi George.

I have completely done what ever you mention I'm still facing some problems.The main problem in this analysis is the contact. I have shared the deck and output file for your reference. Thanks in advance please do give me some suggestions. Thanks 

rev 3_0001.rad

rev 3_0000.rad

rev 3_0000.out

Share this post


Link to post
Share on other sites
Guest

Hi Vijay,

The unit consistency is wrong. If it's grams, the length to be followed is either mm or cm. If you want to follow the length in meter, then mass should be kg. Please scale the model accordingly and modify the material parameters. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...