Jump to content

Hyperstudy batchmode setting

Recommended Posts


I encounter a problem when running Hyperstudy in batch mode in my university's computing server. I tried batch mode on my computer and it worked. But when I copy to the server, there were errors.


Here's brief description of my model:

1. I use tpl model.

2. I want to use batch mode to run the approach "opt_3". opt_3 is copied from opt_1, but I disable some parameter in opt_1.

3. I disable the following execution checkbox of approaches nom, doe, opt_1,opt_2. Only enable opt_3.


After copying xml and tpl file to server, I changed the content of <pathorigin> and <folder> tag in "xml" file.and got some error messages below:


1 Message: Settings location ( d:\Users\cc-161970\AppData\Local\Altair\HyperS
tudySettings.xml )
2 Warning: Could not find argument ( filenames ) in command ( Purge (cmd_purge) )
7 Warning: Could not find argument ( archname ) in command ( Create Archive (
cmd_create_archive) )
22 Error  : No template file specified for model ( Model 1 (m_1) )
23 Error  : All model references must be resolved for ( Optimization 3 (opt_3) )
24 Error  : Validating optimization failed!
25 Error  : AttributeError: 'GenRpt_Hst_Xls' object has no attribute '_intfXls


I have several questions:

1. in message 1: There's no setting file in the shown path. Should I copy one from my computer to that path in sever? Or where could I change that setting location ?

2. for warning 2 and 7, do that matter? what should I do in the xml file?

3. about the errors, it seems the xml file cannot find tpl file. I already modified the path to where tpl is. What else I should do?


I attach my files. If you could guide me a bit, I'll be really grateful.


Many thanks,






Share this post

Link to post
Share on other sites

The settings file information is only a message, there is no need to do anything.


The rest of the messages and errors are because HyperStudy cannot resolve many of the paths and dependencies on the server machine.  Hand editing the xml is error prone and not recommended.  On your local machine, please create an archive (File->Export Archive).  This will create an *hstx archive file.  This is an all-in-package, similar to a zip file.  This package contains all the file dependencies internally and will automatically expand into proper paths on a different machine.  The archive system is the proper way to maintain portability across machines. The archive file can be directly submitted to the hstbatch executable, please see the options in the help.


Also, there is an error about the spreadsheet report, which requires excel to be installed.  I'd guess that it is not installed on the server machine, so you should deactivate that report type.

ChihPeng, Rahul R and John Zack like this

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...