Jump to content
riiily

Assigning Media to Regions and Faces

Recommended Posts

Why can I not assign all the media I have added to my Media Library to the regions and faces of the objects in my FEKO models? What are the rules for assigning media to regions and faces of models? I was told in an email from the FEKO support team that a metal solid is modeled in FEKO not by setting the region of the object to a metallic medium (which is not allowed) but by making the region medium of the object free space, by making the medium of the object "surfaces" (by which I assume was meant "faces") the needed metallic medium, and by making the thickness of those "surfaces" greater than skin depth. I have tried this but the metallic medium I am using, copper, does not appear on all of the model faces I need to model as copper. I am using FEKO 7.0.

Share this post


Link to post
Share on other sites

Hello riiily,

 

Firstly, I would suggest that you upgrade to the latest version of FEKO. The latest version if FEKO 2017.1.2.

 

The information provided by support is correct and this "strange" way of setting the media comes from the original solution method used in FEKO - the method of moments (MoM). The MoM models (usually) only the surfaces and thus all settings are set on the surfaces (or faces). If you want to model a copper cube, you model the faces of the cube as copper, but you then also need to supply the thickness of the faces since this is not available to the solver.

 

Quote

I have tried this but the metallic medium I am using, copper, does not appear on all of the model faces I need to model as copper.

Without seeing the model, I can only speculate as to the reasons for this. If you have set all the regions to free space or a dielectric, you should be able to set the faces to a lossy metal (such as copper). If a region is set to PEC (or Default, that evaluates to PEC for that region), then you will not be able to set the faces to lossy metal.

 

If that does not help, I suggest you provide the model and the face that is not working the way you expect and then I can have a look.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...