Jump to content
ManroopT

Assigning dielectric media to faces.

Recommended Posts

For Plane Wave solution at 24 GHz (MoM/MLFMM/ PO and MoM/MlFMM coupling):

1.

I have imported a cad file from soild works.

Media can be assigned to regions and faces both.

But in this import Feko does not display any region. Geometry consists of only faces.

Face is allowing only Metallic Media or PEC but not dielectric.

 

What should i do to assign dielectric media to this model?

 

2.

Also, if i simulate with PEC, i get error: EPSENT is too large or trianlge size is too small

How to approach this error?

 

3.

What happens if i increase extent of the model in Feko?

 

forum.PNG

face.PNG

Share this post


Link to post
Share on other sites

Hello ManroopT,

 

Quote

What should i do to assign dielectric media to this model?

These faces should be unioned or stitched. When the faces form a closed region, CADFEKO will show the region for that part.

Please don't just select all the elements and union. I would suggest that you select elements close together that can be considered a logical unit and the union these and in so doing build the entire model by union together unions of faces.

 

 

Quote

Also, if i simulate with PEC, i get error: EPSENT is too large or trianlge size is too small

Have a look at

 

Quote

What happens if i increase extent of the model in Feko?

It is recommended that the model extents be set as small as possible for the geometry. Thus, if your model's maximum extent is 200, set the model extents to 5e2. If it is 700, you need to set it to 5e3, but if it is only 0.6, set it to 5e0. This ensures that the geometry is represented as accurately as possible. Note that changing the model extents effectively scales the geometry and could result in faulty faces that may need to be repaired (this only sometimes happens for imported geometry).

ManroopT likes this

Share this post


Link to post
Share on other sites
On 6/20/2017 at 9:57 PM, JIF said:

These faces should be unioned or stitched. When the faces form a closed region, CADFEKO will show the region for that part.

Please don't just select all the elements and union. I would suggest that you select elements close together that can be considered a logical unit and the union these and in so doing build the entire model by union together unions of face

I tried stitching them face by face but still CADFEKO does not show regions.

Which tool shall i use to modify the geometry?

 

Geometry is too complex and contain 14,000 faces. I tried modifying with solid works but it does not worked. What do you recommend at this point?

Drn_mesh.PNG

Share this post


Link to post
Share on other sites
9 hours ago, ManroopT said:

I tried stitching them face by face but still CADFEKO does not show regions.

Which tool shall i use to modify the geometry?

If you stitch / union and CADFEKO does not sow a region, that means that the faces do not form a water tight enclosure (thus, no region exists). You can enable the "Connectivity" display option. This option shows all open edges in red. In order to see a region, there should be no open edges bordering the region.

 

10 hours ago, ManroopT said:

Geometry is too complex and contain 14,000 faces. I tried modifying with solid works but it does not worked. What do you recommend at this point?

There are a few options. With 14000 faces, I would first try to export the model (from the source) in some other format - prefer Parasolid. You can also use HyperMesh to import the CAD and then export Parasolid or even mesh directly in HyperMesh. However, since you want to assign media (and thus regions), I would not try that yet.

 

Are you allowed to share the model so that I can have a look at what the problem is?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...