Jump to content
jcd

Enabling wrap text in TableView cells

Recommended Posts

Is there a command / option that we can use to enable word wrap in TableView cells. Right now, when a cell has data that is longer than its width, it just shows "..." at the end instead of the actual data when I publish the TableView window to an html file. It shows up correctly when I publish a .ppt but not in an html.

 

Any help is appreciated.

 

Thank you.

Share this post


Link to post
Share on other sites
9 hours ago, tinh said:

I don't know how to open TableView,

Could you show me?

 

You can select it from the client selection dropdown in HyperView,

 

Open_TableView.png

 

Although I believe TableView was only introduced in HyperWorks 14.0

Share this post


Link to post
Share on other sites

I found it, @jcd

it use tk treectrl widget

to enable wrapping for TableView, enter command

foreach widget [winfo children .] {
     if {[string match .tblview_* $widget]} {
          catch {$widget.frame.ctl.table element configure etext -wrap word}
     }
}

 

Share this post


Link to post
Share on other sites
3 hours ago, tinh said:

I found it, @jcd

it use tk treectrl widget

to enable wrapping for TableView, enter command


foreach widget [winfo children .] {
     if {[string match .tblview_* $widget]} {
          catch {$widget.frame.ctl.table element configure etext -wrap word}
     }
}

 

@tinh : This is brilliant! Exactly what I was looking to achieve. Thank you so much

tinh likes this

Share this post


Link to post
Share on other sites

×
×
  • Create New...