Jump to content
José Luís Medeiros Thiesen

Spring connection between two componentes

Recommended Posts

I'm modeling a representative volume element that it's basicaly made by a cylinder inserted into a cube. I need to make a spring contact between this two parts, changing the spring stiffness i want to analyse the perfect and the imperfect contact. Anybody has a tip to build this model with spring elements (CBUSH) only in the common nodes between the cylinder and the rest of the cube? Those spring elements need to be at a cylindric system.

 

I have something like this:

 

 

Capture.JPG

Share this post


Link to post
Share on other sites
Guest

You can use either 1D linear to create or use connectors>> Spot weld>> Springs and update to CBUSH with CID

Share this post


Link to post
Share on other sites

Hi together,

 

i try to achieve the same thing. I create the face elements over faces, find faces and put them in two new components. Afterwards i try to connect them over linear 1D. Now I get the error: 2 meshs elem orders differ. Is there anything else i need to consider?

 

After this step, do i have to delete the two face meshes created?

 

Thanks for your help!

 

Sebastian

Share this post


Link to post
Share on other sites
Guest

HI,

 

Do you get this error during analysis or during modelling?

 

I don't see a point for having face elements. 

Share this post


Link to post
Share on other sites

I tried to use the model created by tinh in the earlier post. (cbush.hm) I get the error during the modelling.

 

I extracted the face elements from both components and tried to connect them over 1d linear. 

 

As Input i selected: from (face elems component number one) to (face elems components number two)

 

When i press the create button i receive this error message. (2 meshs elem orders differ)

 

Is there anything I am doing wrong?

 

Is there a need to define the allignment or the density?

 

Thank you for your help!

 

Sebastian

Share this post


Link to post
Share on other sites
Guest

Hi,

 

Did you extract face elements of the elements which are part of hole on blue component?

 

Also check the  alignment as @tinh suggested.

 

Another workaround (You don't have to create face elements)  is to use Connectors>> Spot>> Spring. Select the nodes and components and create CELAS1 elements. Goto connectors browser and delete connectors (not connectors and FE)

 

Now go to springs panel>> update>> change element type to CBUSH>> select all CLEAS1 elements>> update element type.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...