Jump to content
denizbilgili

Problem when defining a multi-body deformable surface contact

Recommended Posts

Dear all,

 

I am trying to define a multi-body deformable surface contact for Optistruct using MBDCNTDS type of interface. Below image shows the doc page for this type of interface. As the docs say, I have made an MBDSRF type node set to use as the deformable surface. I am able to pass this MBDSRF type of set into the SRFID entry of the MBDCNTDS . So no issues with the deformable surface part.

 

However, when I try to make a node set for the SID1 entry in MBDCNTDS, it will not accept any of my node sets which are saved as entity sets. I have tried using many different card images (SET_GRID and many other), still, the SID1 entry of the MBDCNTDS  I'm setting up will not see my node set.

 

I would be grateful if you could share any information with me regarding the type of node set I should use which can be passed into the SID1 entry of MBDCNTDS.

 

Relevant info: I'm using Hyperworks 2017

 

Best regards,

 

Deniz Bilgili

Capture.PNG

Share this post


Link to post
Share on other sites
Guest

Hi,

 

I tried on Student Edition of HyperWorks 2017 and it works fine at my end. 

 

1) Create a set_Grid (which is SID1--> Master in Interface panel)

2) Create a MBDSRF (which is SRFID-->Slave set in Interface panel)

Share this post


Link to post
Share on other sites

Hello Prakash,

 

Thank you for your response, and apologies for my late response, I have been out of work for some time.

 

When I use the Analysis -> Interfaces -> Add panel, I am able to select a SET_GRID for SID1 and MBDSRF for SRFID as you said. However, when I use the Analysis -> Interfaces -> Create panel to create an interface and then use the tree item to assign entity sets to SID1 and MBDSRF, the problem I mentioned in my first post occurs. Please see below images.

 

1.png.df65f53b6471122281239840a607b59d.png

Figure 1

2.png.a06784c6f0b898f0737803119d8534c9.png

Figure 2

 

 

Another point is, when I use the Analysis -> Interfaces -> Add panel, it does let me select a SET_GRID for SID1; however, even though the tree item says 1 set is assigned to SID1, when I press on the sets button as shown above in Figure 1 to view the assigned set, it again gives me a blank screen just like it shows in Figure 1.

 

Could this be a possible bug? I haven't tried to run an analysis so I do not know yet whether it will be able to use the assigned sets or not.

 

Thank you for your time,

 

Best regards 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...