Jump to content
riiily

Mesh Triangle RunFEKO Error with RL-GO

Recommended Posts

I'm trying to simulate an electrically large structure (a plane) with geometry imported from SolidWorks using RL-GO running on FEKO v14.0.430. I have run the simulation for three different GO ray increment settings and for each trial, RunFEKO has returned the same error, although at different levels of simulation completion: 

ERROR 47000: Triangle #13 is incorrect on curvilinear mesh for RL-GO. A finer mesh that more accurately represents the geometry could resolve the problem.

See also message in the output file Boeing737_400_0.7incsbasic.out

 

How can this error be eliminated and what caused it? I wasn't aware GO mesh density could be controlled (and I have to use GO for this simulation). I'm always worried CAD imports will cause issues but haven't experienced many problems with other imports so far and haven't encountered this error before either.

 

Boeing737_400_0.7incsbasic9_1_17.zip

Share this post


Link to post
Share on other sites

Hi riiily,

 

I see both a warning and an error message. I will first address the error message you encountered and then also suggest a solution for the warning that you did not mention. The mesh for any solver can be easily defined by selecting "Coarse", "Standard", "Fine" from the Create Mesh dialog box. However, I rarely use these general settings because a custom mesh is almost always more efficient/accurate. A custom mesh can also be defined for any solver including RL-GO. Please switch to the Mesh tab in CADFEKO and select Create Mesh from the left-side of the ribbon. A dialog box will appear that allows a user to select "Custom". Users can then define global mesh settings for mesh elements, which in your case will be triangle edge lengths. The advanced tab on this dialog box also allows more customization with regard to curved surfaces including whether curvilinear elements should be used. Curvilinear elements are available for RL-GO with some hidden consequences. A flat triangle can be used to approximate a curved surface, but each local triangle does not know the radius of curvature being approximated. A curvilinear element does know the local radius of curvature, so diffractions from these curved surfaces can be computed. Curvilinear elements allow less triangles and less resources to be used, but including diffraction components increases the computational resources. The total resources tend to be about the same order of magnitude with curvlinear elements potentially providing a more accurate answer.

 

I would also recommend you upgrade to the latest version of FEKO (currently 2017.2). There is an option available to automatically select the angular increments to launch rays with several other hidden features for efficiency. Several of these features have been refined in more recent versions. You can activate the Auto feature by switching to the Solve/Run tab in CADFEKO, select Solver Settings from the ribbon and then switching to the High Frequency tab in the respective dialog box. Toward the bottom is a radial option that enables Auto Settings for a more user friendly experience. This suggestion should eliminate the warning toward the top of your OUT file.

 

There is also a note stating you are using sequential processing (a single core). Every solver available in FEKO has parallel processing efficiently implemented. I would suggest multiple cores to achieve faster results.

 

Regards,

Derek Campbell

Senior Application Engineer

Share this post


Link to post
Share on other sites

Hello riiily,

 

I had a look at your model and there are indeed alignment problems with the CAD that should be cleaned up. I have the following recommendation (in addition to what Derek suggested - especially the suggestion to upgrade to the latest version).

 

If you take a look at triangle 13 in your model, you will see it is the triangle indicated with red edges in the image below:

Triangle13.png

 

I think it is easy to see why any solver would find such a triangle troublesome. Triangles (even curvilinear) need to look like triangles and the curvilinear triangles should have reasonable curvature (no extreme curvature or triangles folding back on themselves). For a model like yours, you should be able to improve the mesh by setting the curved geometry approximation settings (see below where I changed the refinement factor and minimum element size to produce a better mesh). Local mesh settings can also be applied to faces or custom mesh settings can be applied globally in order to get an accurate (representative mesh). Increasing the number of RL-GO elements should not have a huge impact on your simulation time and resources (not like MoM where it has a huge impact).

Screenshot 2017-09-03 10.21.17.png

 

I suspect the warnings are and errors are due to CAD problems. The warnings are probably due to the source being exactly in the plane of some of the faces (extreme grazing incidence). The error is most likely due to the CAD that is not correct. See the image below where faces (regions) intersect (that should not). This should be fixed before attempting to solve the model.

CAD_overlap.png

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...