Jump to content
re2087s

Model Visualization / Intersection of different Surfaces after Creating Laminate

Recommended Posts

Hi,

 

i have a problem regarding the correct visualization and therefore results of my model.

I have a wheel model which is going to be made of carbon fiber. It is kind of an T-shape, but not really, see following screenshots.

59a9b4532211f_2017-09-0114_25_46-Untitled-HyperWorksv14.0-OptiStruct.thumb.jpg.e6dfe6a7ee5ff407c9df0f2254cdc0cb.jpg59a9b45c01e68_2017-09-0114_25_24-Untitled-HyperWorksv14.0-OptiStruct.jpg.9c1c6240c8f3799a2ca8bbf9ce3608f8.jpg

After creating the laminate, the curved surfaces intersect even though I am using the interface laminate feature with two sublaminates. The element normals of the blue surface face in the y-direction, the element normals of the yellow surface and vertical surface face in the -y-direction.

59a9b25406273_2017-09-0114_17_18-Untitled-HyperWorksv14.0-OptiStruct.jpg.64d9bb4be604fff4301d542efaffc4a9.jpg

The interface laminate feature works on the middle, vertical surface of the wheel, but you can also see that the laminates of the shells intersect while the vertical surface works properly. This is why I have a sharp step in the front of the wheel and a less sharp step in the back of the wheel and it looks like the plies are interrupted.

 59a9b3aa86378_2017-09-0114_09_57-Untitled-HyperWorksv14.0-OptiStruct.thumb.jpg.d92c495b3a3ab77b2cf90cc8038f8ec4.jpg59a9b59a22907_2017-09-0114_30_55-Untitled-HyperWorksv14.0-OptiStruct.jpg.fd073c4e974eaabd3a5958e51e0f88bb.jpg 

59a9b37d91381_2017-09-0114_11_08-Untitled-HyperWorksv14.0-OptiStruct.thumb.jpg.4c995bb3c3953e73218803819e1faf76.jpg

So I would like not to have those steps or intersection plies but instead a smooth transition from the shells to the vertical surface as it is in the 2D model. I attached many pictures so it is better to explain and imaginable. Also I considered that i have to choose the interface plies with regard to the element normals:

59a9b691686b7_2017-09-0114_34_44-EditLaminate.thumb.jpg.cacfef16b7077d8f8471f069eaa1bd11.jpg

 

Pleas let me know if you have further questions to this problem. I also found different forum posts but they do not help me because they are more like real T shapes where as mine is not.

 

Thanks in advance!

 

 

Share this post


Link to post
Share on other sites
Guest

Hi,

 

This looks a little difficult to model. It would be better if you share the model for better understanding. 

Share this post


Link to post
Share on other sites
Guest

Hi Ricardo,

 

I think there is some problem with the mesh.

 

Can you split the row the elements highlighted in the picture below?

split.PNG

Share this post


Link to post
Share on other sites

Hi Prakash,

 

first, I would like to explain to you why I did it this way. The thinking behind having continuous surfaces and mesh was that the plies should be continuous coming from the shells and ending in the big circle in the middle of the wheel. So, wouldn't your advice (to split the surfaces) have the opposite effect? This is also why I connected the single surface in the middle with both shells (yellow line), so that the mesh is continuous as well as the plies. If not, how can I split it the way you told me to do? I am trying to do it with the quick edit tools "split surf-line" but it does not really work. To put it in a nutshell, there shouldn't be any steps from the inner, circular surface (with the holes) to the shells. The plies should be continuous resulting in 24 layers in the inner, circular surface (with the holes) while the shells have each 12 layers. The shells share the inner, circular surface. Apparently the layers of the shells intersect each other when thickening them, also because Hypermesh lays the plies up symmetric to the model surface, leading to those steps. So, 6 on one side of the surface and 6 on the other. If this is changeable, this could solve the problem, too, maybe. I tried different laminate options but it didn't lead to the correct visualization.

 59b01fae1f419_2017-09-0611_17_38-Untitled-HyperWorksv14.0-OptiStruct.jpg.2271d21855954a1b40e6c7464d4132a9.jpg

Share this post


Link to post
Share on other sites

I got it!

 

In the PCOMPP Property I had to type in a 0 in the Z0 panel. This allows the software to lay up the model in the direction of the element normals and not symmetric to the model surface.

 

Riccardo

Share this post


Link to post
Share on other sites
Guest

Hi Ricardo,

 

This is strange. I have a similar model but works without having z0. I will investigate further if the issue is with version. Thanks for letting us know.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...