Jump to content
Chennakesava Kadapa

missing white spaces in grid data in exporting mesh

Recommended Posts

Hello everyone,

I am having trouble exporting the mesh from Hypermesh. Some white spaces separating the fields are missing.

 

*)  With the RADIOSS profile, the first three nodes of the grid data look like this.

         1    10.4352852680878   0.374999999999996    1.69690861652916
         2    10.0920996147679-3.8857805861880E-15    1.59540682856021
         3    10.2957517115474-3.5527136788005E-15    1.49409343503715

 

*) The situation is even worse with OptiStruct. The output file (first three nodes) looks like this.

GRID           1        10.435290.375   1.696909                        
GRID           2        10.0921 0.0     1.595407                        
GRID           3        10.295750.0     1.494093                        
 

I don't want to create white space manually because the meshes I work with, in general, contain thousands of nodes. So, I need a proper solution for this issue. I am using the HyperWorks14.0 - student version.

 

Thanks,

Chenna.

Share this post


Link to post
Share on other sites
5 hours ago, Chennakesava Kadapa said:

Hello everyone,

I am having trouble exporting the mesh from Hypermesh. Some white spaces separating the fields are missing.

 

*)  With the RADIOSS profile, the first three nodes of the grid data look like this.

         1    10.4352852680878   0.374999999999996    1.69690861652916
         2    10.0920996147679-3.8857805861880E-15    1.59540682856021
         3    10.2957517115474-3.5527136788005E-15    1.49409343503715

 

*) The situation is even worse with OptiStruct. The output file (first three nodes) looks like this.

GRID           1        10.435290.375   1.696909                        
GRID           2        10.0921 0.0     1.595407                        
GRID           3        10.295750.0     1.494093                        
 

I think this is "fixed format" of Optistruct. No spaces, no problem :) because the reader will work on the length of input data.

Have a look at Reference Guide:

OptiStruct_2017_Reference_Guide.png.248256c1e0658f57a365445646f7cfcf.png

Share this post


Link to post
Share on other sites
Guest

Hi Chenna,

As Nguyen-Dai told this is a fixed format. We suggest you to install Textpad and open the starter (_0000.rad) file in Textpad which shows better alignment of keywords and numbers.

As a general note, for nodes in RADIOSS the format is as shown below.

For more information please go through the Reference Guide of RADIOSS, which can be downloaded from  http://forum.altairhyperworks.com/index.php?/topic/20652-radioss-2017-reference-manual-documents-user-guide-and-tutorials/

 

node.PNG

Share this post


Link to post
Share on other sites

Thank you Nguyen and George, for your answers.

 

Unfortunately, they do not help my cause. I am using Hypermesh only to generate meshes for my in-house FEA code. So, the RADIOSS reader does not help me. I have to have the coordinate with some delimiter which I can process to be readable into my code.

 

Textpad is my default text editor. I also opened the .rad files in Notepad, Wordpad and MS Word, and I didn't see any difference in the format. I have attached the file for your reference. Please not me know if I am doing something wrong.

 

The only option I can think of now is to generate to an AWK script to break the coordinates.  I must say that this is very inconvenient. Please let me know if there is any other way around this.

leafvalve3dleaf_0000.rad

Share this post


Link to post
Share on other sites

Hi , you can try this way

- use optistruct profile

- set up a temporary loadcase (just to run optistruct)

- enter analysis > control cards> ECHO : this will make OS write out GRID, ELEMENT,.. to *.out file

- export data to *.fem file

- to activate comma delimiter when OS echo, open *.fem file and add line "ECHOON PARSED" below the line "ECHO"

- save *.fem file and run OS, then open *.out file to copy data with comma delimiter

Share this post


Link to post
Share on other sites

Thank you all for your answers.

 

I did not like Tinh's solution because I do not like the idea of running a solver simply for the sake of obtaining a better format for the mesh data. It is cumbersome. 

 

@Nguyen, I could not figure out what "fixed format" and "long fixed format" are. I don't see them in v14.0.

 

I solved my problem by

1.) developing a simple awk script for the file generated using v14.0, 

2.) installing 2017 version in which Optistruct has 'free format' which exports the data in comma separated format which I can process easily.

 

Thank you.

Share this post


Link to post
Share on other sites

Well there is actually 2 solutions : 

%% First one : Standard format. In this case the *fem file is written like 

GRID           NumOfNode        XCoordYCoordZCoord   % NB = XCoord, YCoord and ZCoord contain 8 characters, It's easy to write a code to separate all this things 

 

%% Second One : Long Format. In the second case, the *fem file can be read easily !!

GRID*          NumOfNode             XCoord        YCoord        

*       ZCoord

 

Cheers ! 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...