Jump to content
ALM

Problem using continuous range at the frequency setting

Recommended Posts

Hello !

I am facing a problem while using continuous range option from the frequency setting,  I don't get more then 4 samples even if I require 10 for example. I have tried to use a  for loop but it didn't work either  , how I can get the required data in function of frequency samples ?! (Note: I have check in the forum and the only thing I have found was the for loop suggestion for a similar problem but it didn't work for me). Thank you! Best regards!

Share this post


Link to post
Share on other sites

Hi @ALM,

 

Could you attach a model?  Did you set up the configuration in CADFEKO or in EDITFEKO (I'm asking because you mentioned a for loop)?

 

You can maybe check whether the maximum number of samples or the minimum step size is set.  These both serve to limit the number of samples and could result in something like this.  Another problem could be that the convergence algorithm isn't checking whether all of the results are converged.  The defaults are usually fine but if you are looking at surface currents, then it might be switched off.

 

Alternatively, you can try using linearly spaced points for now.

 

I hope this helps!

Share this post


Link to post
Share on other sites

thank you for your reply!

the model is create within CadFeko then I swithed to Edit feko in order to perform the for loop as the continuous range option gives me only 4 files as output so 

 I have checked the settings several times but the still getting the same thing. here is the for loop I am using.

#start_frequency = 2.2e9
#end_frequency   = 2.5e9
#freq_Samples    = 10
!!   for #i =1 to #freq_Samples step 1
#this_frequency = #start_frequency + (#i-1)*(#end_frequency - #start_frequency) /(#freq_Samples -1)
FR:  :  :  :  :  : #this_frequency
** the other cards were omitted just for clarity 
!! next
EN

 

Share this post


Link to post
Share on other sites

Thanks @ALM,

 

I'm attaching three models that you can take a look at.

 

editfeko_forloop.pre

This is essentially what you provided above and (as far as I can tell), it works as expected.  The PREFEKO language (what you use in EDITFEKO) can be quite tricky.  New solution configurations are triggered by certain cards (e.g. a new source and a solution request).  If your loop didn't contain certain triggers, then it's possible you wouldn't have seen all ten configurations.  The model that I attached shows that your loop is configured correctly, provided the rest of your configuration is fully configured.

 

The downside to this method is that it is more complex to configure and results in ten independent configurations.

 

editfeko_freqrange.pre

This model shows a simpler method to request a frequency range in EDITFEKO.  The FR card has an option for you to specify a start frequency, end frequency and the number of points:

FR: #freq_Samples : 0 :  :  :  : #start_frequency :  : #end_frequency

FEKO will then take care of the loops and store the results in one configuration.

 

cadfeko_freqrange.cfx

Finally, I'm adding a CADFEKO model (created with CADFEKO 14.0.432-293039 (x64) from 2016-12-06) that requests a frequency range from 2.2GHz to 2.5GHz using 10 samples.  This is by far the simplest (and safest) way to configure a model and would be the recommended method.

 

On 10/21/2017 at 9:02 PM, ALM said:

the model is create within CadFeko then I swithed to Edit feko in order to perform the for loop as the continuous range option gives me only 4 files as output

My best guess is that you were using the "Continuous (interpolated) range" option to specify the frequency.  For this setting, FEKO will decide for itself how many points are needed in order to accurately represent the simulation data.  In your case, it's possible that the algorithm was satisfied to stop after four points.

frequency.png.2877a3876e7b93b6439ac3642e03bc7b.png

If the results are inaccurate, you can increase the "convergence accuracy" to "High".  Otherwise, your problem could be that the mesh is too coarse or there is some other problem with the model setup.

 

If this still doesn't help, please attach an example model so that we can see what you're working with.

Share this post


Link to post
Share on other sites

Obtaining so few samples could also happen if your model construction is wrong, for example, if you have some antenna but your port is somehow not connected to the antenna, or your antenna is supposed to radiate at say 1 GHz but you are solving for 100 MHz. Then the S11 would be zero and there would nothing to interpolate really over the band, i.e just a flat line response.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...