Jump to content
Kin Poh

optistruct RBE3 conver to Radioss

Recommended Posts

I tried to convert optistruct RBE3 to Radioss format in Hypermesh. 

After conversion, the RBE3 become RBODY which is fine, but all my dependent nodes disappeared. 

My original dependent nodes are 6-10 nodes, after conversion, only 1 dependent node remaining.

 

Is that my step is wrong or any other step i need to follow?

Share this post


Link to post
Share on other sites
Guest

Hi Kin,

Instead of RBE3, try creating RBE2 in OptiStruct and convert the same into RADIOSS. Please try with this option.

Share this post


Link to post
Share on other sites
Guest

Hi,

From 1D page, select config edit panel, select the RBE3 elements and select the new config as rigidlink and click switch so that the element type will be switched to RBE2.

 

ce.PNG

 

 

rl.PNG

Share this post


Link to post
Share on other sites

Hi George,

 

It works!!!!

Thanks a lot.

 

Can I further my question here with the Optistruct conversion to Radioss?

 

I am converting CBEAM circle section to Radioss, it turn to BEAM3N, It is fine but the BEAM3N need to redefine the cross section.

I had redefine the BEAM3N cross section as circle, when I export to .rad file and using hypercrash to look into it, the circle is not defined.

How is this can be happen ?

Any faster way to convert the CBEAM (Optistruct-PBEAM) to BEAM3N (Radioss /PROP/BEAM) with full information with it?

 

Thanks

Kin Poh

Share this post


Link to post
Share on other sites
Guest

Hi Kin Poh,

I tried the same with a simple model and it worked well in HyperMesh.  Instead of HyperCrash can you check in HyperMesh?

Share this post


Link to post
Share on other sites

Hi George,

 

It work fine in your model for which question?

 convert the CBEAM (Optistruct-PBEAM) to BEAM3N (Radioss /PROP/BEAM)?

I can convert it successfully but the property side does not remain the same.

 

Thanks.

 

Kin Poh

Share this post


Link to post
Share on other sites

Hi George, 

 

I got this list, but it does not happen in my case.

You could try it with simple model, In OS BEAM cross section as circle(using hyperbeam to define), then see how it turn to Radioss after convert. whether the cross section remain the same.

 

Thanks.

Kin Poh

Share this post


Link to post
Share on other sites
Guest

Hi Kin Poh,

I created a circle section in OS and converted to RADIOSS, and the cross section was retained. These steps were captured in a screen capture tool and attached along for your reference. 

The file is saved in .swf format, which plays in GOM player.

OS_to_Radioss.swf

Share this post


Link to post
Share on other sites

Hi George,

 

I follow all the step of you referred in the .swf, but it end up still fail.

Please see below picture. 

My beams section also seems name changed, and not working anymore in the BEAM3N

 

image.thumb.png.03ed0da9fdd9e35a949c79dd76a0210a.png

image.png

Share this post


Link to post
Share on other sites
Guest

Hi Kin Poh,

Please use the Secure File Dropbox link in my signature, so that the model file will directly come to my inbox.

 

 

Capture123.PNG

Share this post


Link to post
Share on other sites
Guest

Hi Kin Poh,

In the beam property tab, instead of 'Do Not Export' option change it to Export option, as shown in the image below and try converting the mode to RADIOSS.

export.PNG

Share this post


Link to post
Share on other sites

Hi George,

 

My option is always showing "Hide In Menu/Export". even in the example that I send to you.

Could you help to demo a .swf with my example sending?

I still could not get it from my side.

 

Thanks.

 

Kin Poh

Share this post


Link to post
Share on other sites

Hi George,

 

it worked but not perfectly work, anywhere I am able to change the config from generic to standard, then able to use the beam section (hyperbeam).

 

But i have another question, when I export it as Radioss solver, the hyperbeam section gone, and I use hypercrash to import the solver deck, it changed.

How can I remain the hyperbeam section as below in the solver deck and hypercrash?

image.png.b9c5e3f0976142f2f6ad2ebfcbafdde1.png

Share this post


Link to post
Share on other sites
Guest

Hi Kin Poh,

HyperCrash visualizes all beams like an 'I' section (that is it is just to show that it is a 'beam') and it doesn't show the actual cross-section. So even if you had a tube, or box section, HyperCrash would show it as an I section. In fact for RADIOSS there is no tube, box etc... just the basic properties. When HyperMesh is used and it associate a Hyperbeam section, HyperMesh will show that section (linked through HM comments) but on the RADIOSS side it is just passing the section area and inertia.

 

Share this post


Link to post
Share on other sites

Hi George,

 

With the section area and inertia info, yes, it passed the info to the prop/beam.

Example, If my type of cross section is tube in HM with hyperbeam, after that in hypercrash it shows the same section area and inertia, can I treat it as the same for my crash simulation?

 

Thanks.

 

Kin Poh

Share this post


Link to post
Share on other sites
Guest

Hi Kin Poh,

Yes, RADIOSS doesn't have 'standard sections' they are just area and inertia and so the solver will take the same information.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...