Jump to content
hnaceur

AcuFieldView OpenGL error

Recommended Posts

Hi all,

I am struggling with AcuFieldView  crashing on some computers in my engineering school, where I got an error when launching AcuFieldView with the following message :

Warning: detected OpenGL error 'invalid enumerant' at Before Renderer::compile.

 

Please see the attached screen capture of the error message.

 

I also copied below all the content of the MS-DOS window when AcuFieldView tried to launch.

 

I know it is related to the graphics card of the computers, but is there any options in the initialization files of AcuFieldView which I can use to overcome the problem.

 

Please any help would be grateful !

 

Thanks,

Hakim

 

-----------------------------------------------------
AcuFieldView: Requesting a license ...
Data Guide enabled

Current working directory is C:\Users\hnaceur\Desktop\Ex1_Poiseuille

Loading plugins from "C:\Program Files\Altair\2017\acusolve\win64\fv\bin\plugins"
Loaded plugin C:\Program Files\Altair\2017\acusolve\win64\fv\bin\plugins\acusolve_reader.dll
Loaded 1 plugin toolkit
FBO usage :       15.2 MB = 1068 x 620 x 6 x 4
FIELDVIEW using FBO rendering.
Warning: detected OpenGL error 'ÚnumÚrant non valide' at Before Renderer::compile
Warning: TextureRectangle::apply(..) failed, texture rectangle is not support by your OpenGL drivers.
Warning: TextureRectangle::apply(..) failed, texture rectangle is not support by your OpenGL drivers.
PixelBufferWin32::init(), Error: some wgl extensions not supported
Warning: RenderStage::runCameraSetUp(State&) Pbuffer does not support multiple color outputs.
PixelBufferWin32::init(), Error: some wgl extensions not supported
Warning: detected OpenGL error 'invalid enum.'
PixelBufferWin32::init(), Error: some wgl extensions not supported
Warning: RenderStage::runCameraSetUp(State&) Pbuffer does not support multiple color outputs.
PixelBufferWin32::init(), Error: some wgl extensions not supported
Warning: TextureRectangle::apply(..) failed, texture rectangle is not support by your OpenGL drivers.
Warning: TextureRectangle::apply(..) failed, texture rectangle is not support by your OpenGL drivers.
Warning: detected OpenGL error 'invalid enum.'
Warning: TextureRectangle::apply(..) failed, texture rectangle is not support by your OpenGL drivers.
Warning: TextureRectangle::apply(..) failed, texture rectangle is not support by your OpenGL drivers.
Warning: TextureRectangle::apply(..) failed, texture rectangle is not support by your OpenGL drivers.

 

Acufieldview_opengl_error.png

Share this post


Link to post
Share on other sites

Hi @ydigit

I tried what you suggested by adding the environment variable FV_RF_GRAPHICS = 1

unfortunately it did not solve the problem, still AcuFieldView crashing on some computers.

 

Please any help will be appreciated

Hakim

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...