Jump to content
denizbilgili

Output ASET DOF only for Adams MNF file for flexbody models

Recommended Posts

Dear Support Team,

 

I use Hypermesh and Optistruct to build flexbody models to use in MSC Adams MBD models. Since my flexbody models are large and have too many unused DOFs, I need to reduce them only to ASET DOFs. In the particular problem I'm trying to solve, I have a machine part with a few ASETs to attach/constrain it and a single location where I get response data from. So, the only DOFs I need are the DOFs of this response location (in addition to the DOFs of other ASETs). I can put an ASET on this location but I don't know how to force Optistruct to output only ASET DOFs to the generated Adams MNF file.

 

In the docs for Optistruct MODEL solver card, Comment #1 states that: "For CMS superelements output in h3d format, only the ASET DOF are output when the MODEL data is not present."

 

I need this same effect but with MNF format and not h3d format, since I work with MSC Adams and not Motion View. I have tried a few ways on my own but have been unable to succeed. Any help would be greatly appreciated.

 

Best regards.

Share this post


Link to post
Share on other sites

Hello Prakash,

 

Thank you for your response. Since my flexbody models are very large and simulation times are rather long, it is very crucial for me that I export only ASET DOFs to the MNF files; otherwise I won't be able to work with my model at all due to very long computation times. I hope there is either a direct solution or an equivalent workaround to achieve the same effect.

 

Update: If there is a way of achieving this by using another profile in hypermesh, say, Nastran, then I'd like to know that as well since I can try to use another profile and thus another solver than Optistruct.

 

Best regards

Share this post


Link to post
Share on other sites

Hello Prakash,

 

I have tried with the settings you gave me. When I use MODEL,NONE,NONE,NORIGID in the fem file, the generated mnf file raises below error in Adams.

 

ERROR: Flexible body .MODEL_1.FLEX_BODY_1 requires one or more modes for constant, partial, or full inertia coupling.

 

So it seems that when I use MODEL,NONE,NONE,NORIGID, no DOFs are exported at all. When I try the same with MODEL,NONE,NONE,RIGID I get the same results as before (namely, the full flexbody solution). My CB solution for the flexbody model has 10 modes plus 1 ASET, constrained in 6 DOFS. So I expect to have 16 DOFs in the full model. The MNF generated with MODEL,NONE,NONE,RIGID has 16 DOFs when I check it in Adams.

 

I can verify this with the file sizes of generated mnfs too. MODEL,NONE,NONE,NORIGID generates an mnf of 5 kilobytes while MODEL,NONE,NONE,RIGID generates an mnf of 48 kilobytes. So MODEL,NONE,NONE,NORIGID one is nearly an empty file due to no DOFs being exported.

 

I would appreciate further help with this issue.

 

Kind regards

Share this post


Link to post
Share on other sites

Hello,

 

I would like to remind that I am still looking for a way of generating superelements with Craig-Bampton Method in Optistruct for Adams (MNF file format). I would like to know if there is a way around. So far, I have tried a few ways combining PLOTEL, NORIGID and NONE in the MODEL card but still no luck. Thank you.

Share this post


Link to post
Share on other sites

Thanks Prakash. Sorry, I thought the case was forgotten. I have checked the .fem and .mnf you shared. In MODEL, Elset is set to ALL but the docs say for CMS SE generation it is defaulted to NONE. But mnf OUTPUT captures no modes in the mnf file when it is set to NONE so I think we'll have to wait for the devs to share what they find. I'll be waiting for your response. Thank you for your time.

Share this post


Link to post
Share on other sites
Guest

HI,

 

I have shared the info already. I will get in touch with you once I have any feedback from them,

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...