Jump to content
vigneshtamil

Adding new material into database. How to create notepad file with material properties

Recommended Posts

Hello,

I am using hyperform to evaluate the springback compensation of a component. I need to add a new material in the hyperform database to run the simulation. I created a notepad file with the material properties and saved it in the installed path of the hyperform in the respective material folder. The name of the material which I added is displayed in the software while creating parameters for the simulation. But the properties of the materials are not listed. I tried with the following extension files - .rad and .txt and .wri. But I could not choose the material to run the simulation. May I know the format how to create the notepad file with the material properties and in which format should it be created.

Thank you and I kindly request you to help me regarding this issue.

Share this post


Link to post
Share on other sites

Why don't you create that material in hypermesh, then on panel material you just need to click "add to database"

should not change material folder manually

Share this post


Link to post
Share on other sites

Hi, but in the hyperform software, in the materials panel I have some default added materials only and I have an option as 'User'. But I do not have options to add the materials. I have added a screenshot of it. Kindly refer to it and help me. Thank you.

Material Database.JPG

Share this post


Link to post
Share on other sites

Hi, 

Thank you very much for the reply. I followed the steps and was able to add the material successfully.

 

Also, when I run the simulation with the default mesh size 10, the simulation is running for more than 10 hours. But for some other material, the simulation gets over in an hour. So will the time required for the simulation vary depending on the material, even though the other parameters are the same. I have attached with the simulation file running. Can you kindly check if the file is running without errors. May I know usually how much time does the simulation takes?

 

Thanks in advance.

Simulation.JPG

Share this post


Link to post
Share on other sites

Hi,

 

 please check the bottom of your image for an estimated 'REMAINING TIME' 

you may also speed up the process by modifying certain settings. Goto preference>Hyperform settings>process defaults tab> radioss mode and choose between speed and accuracy

 

image.png

 

you may also increase the computing capacity available for solving by assigning the number of processers . Goto preference>Hyperform settings>settings tab> RADIOSS_ARGUMENTS tab and assign appropriately. 

 

image.png

 

many factors affects the run time including the mesh size. using adaptive mesh increases the run time. hope this helps

 

 

 

 

Share this post


Link to post
Share on other sites

Hi, thank you and I will check with it. I have one more doubt and it would be great if you can help me with it.

 

I am using Incremental Radioss. There are few default material available in the database. When running the simulation with those default material, the simulation runs successfully (though it has 0 errors and 2 warnings. The warning is related to the material property). But I am using a different material which I add it in the database manually. When running the simulation with the manually added material, I get the error in simulation running or the simulation gets stopped in the middle while it is running few animation files. In the summary page, I get 0 errors and 2 warnings, the same one which I got while running with the default materials. The difference is that, the simulation gets over when running with the default material but it isn't getting completed with the manually added materials.

The material I am adding is DP1200 steel.

 

Have attached with the screenshot of the error.

 

Error : 2 warning id :1084

          Warning in material law1

 

When referring to material law1, it says it is related to the elasticity of the material. But I have given the input values properly.

 

Kindly help me as soon as possible and thanks in advance.

error file.jpeg

Share this post


Link to post
Share on other sites

Can you share with us your material file (.rad) and show me how do you input this material into HyperForm?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×