Jump to content
Yatish Chandra

AcuSolve memory problem

Recommended Posts

Hello everyone,

 

I am currently simulating an entire truck assembly in a wind tunnel environment using the AcuConsole pre processor and AcuSolve solver. I have around three porous mediums in my model along with 18 axial fans (Rotating reference frames) which has blown up the overall element size and also the complexity of the model.

 

When I try to run the model setup in AcuSolve, after the domain has been decomposed, I get the following errors:

 

acuRun: Run acuSolve ...
acuRun: set KMP_AFFINITY=scatter
acuRun: set MP_SET_NUMTHREADS=72
acuRun: set OMP_NUM_THREADS=72
acuRun: set OMP_DYNAMIC=FALSE
acuRun: set MPC_GANG=OFF
acuRun: "C:/Program Files/Altair/2017/acusolve/win64/bin/acuSolve".exe -np 1 -nt 72
acuSolve: AcuSolve checked out license from HyperWorks
acuSolve: *** ASSERTION in Function <memAlloc> File <mem.c> Line <129>
acuSolve: *** Unable to allocate <290044352> bytes; already allocated <73318612992>; from file <topSd.c> line <1451>
acuRun: *** ERROR: error occurred executing acuSolve"
acuRun: Wed Apr  4 16:07:48 2018
 
I have tried to change the mesh size and restart my computer but nothing seems to fix this issue. Could anyone provide more insight into this issue? I am also attaching the log file for reference.

From what I can understand, it looks like a problem with my workstation not having sufficient memory to run the analysis. I am running it on a 36 Core (72 logical processors), 64 GB machine.

 

Thanks,
Yatish


 

AssemFan.3.Log_acuTail.txt

Share this post


Link to post
Share on other sites

Apparently the RAM on the machine is not sufficient to run the problem.  Looks like it's gone through all the physical memory, and into the swap memory, too.  Simplest/cheapest fix would be to get more RAM for the machine if it's not maxed out.  Otherwise, the mesh count (problem size) needs to be reduced.

Share this post


Link to post
Share on other sites
19 hours ago, acupro said:

Apparently the RAM on the machine is not sufficient to run the problem.  Looks like it's gone through all the physical memory, and into the swap memory, too.  Simplest/cheapest fix would be to get more RAM for the machine if it's not maxed out.  Otherwise, the mesh count (problem size) needs to be reduced.

 

Thanks for the input @acupro . I'll try to reduce the mesh count and try it again.

Share this post


Link to post
Share on other sites

Another option would be to define maximum number of elements in AcuConsole. This way the meshing stops after that number is reached. You would of course get an error, but it would avoid the machine hanging or creating a huge mesh that would take too long on your machine.

image.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...