Jump to content

Recommended Posts

Hi everyone,

i tried to implement shock absorber in a shock analysis in optistruct.

I use tutorial in order to set non linear tranisient analysis.

I implement with table1d and pbusht the curve ForceVSdisplacement and applying a force i have checked if the the curves is right.

Then i have to checked if my model with this non linear springs has a right answer to established input.

 

In this case the model is loaded with an initial displacement and a gravity. 

 

Finally i hate to load model with a curves VelocityVSTime.

Now i'm stopped at check problem.

 

 

My doubt are:

  • the initial dislacement is inserted with IC and TIC in model but in the result there isn't initial dipslacement. Why?
  • The tstep is calculated by solver? Is possible have a fixed timestep?
  • maybe more simple simulate this problem with a explicit solver as Radioss?

 

Thank you for the answeres


 

 

Share this post


Link to post
Share on other sites
Guest
11 hours ago, Salvatore said:
  • the initial dislacement is inserted with IC and TIC in model but in the result there isn't initial dipslacement. Why?
  •  

Hi,

 

In your model, I see you have applied Initial velocity and in the results it can be seen, 

TIC.PNG

 

11 hours ago, Salvatore said:
  • The tstep is calculated by solver? Is possible have a fixed timestep?
  •  

Did you try with DT on NLPARM?

Share this post


Link to post
Share on other sites

Hi Prakash,

i agree with you, i have tested also with velocity as TIC, but i don't read this oscillation in my model both with velocity and displacements.

have you modified something? 

 

Regarding Tstep, i have modified Dt on NLPARM but with this parameter i modify only initial time incrmement. i would have costant time increment. is it possible??

 

Furthermore i have modified also TTerm because my analysis has to last 0.5s.

 

 

Thank you for fast answer.

 

 

 

 

Share this post


Link to post
Share on other sites

Hi prakash,

i have changed type of analysis ans now i'm using a geom non linear analysis.

In this way i have control on tstep thorug TSTEPNL.

 

But i haven't resolved the problem of IC.

 

Can you help me?

 

thenk you.

Share this post


Link to post
Share on other sites
Guest
22 hours ago, Salvatore said:

i agree with you, i have tested also with velocity as TIC, but i don't read this oscillation in my model both with velocity and displacements.

have you modified something? 

yes, I deleted the existing and recreated another one.

 

Regarding time increment, I will let you know. 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...