Jump to content
Karthic

Contact Penetration in Sliding

Recommended Posts

Hi,

As shown in GIF, facing penetration issue for surf to surf continuous sliding contact.

1. Tried changing the master and slave

2. Tried S to S and node to surface

3. Used Pcont,  tried stiffness value (1000 & 100000) , auto, soft & hard

4. Also tried changing material

5. Tried with Opengap, Norm

But still I couldn't correct the penetration issue

 

The fem file is attached to this. Please do help me with the issue.

 

gif.gif

trial-2.fem

Share this post


Link to post
Share on other sites

@Karthic 

If you can see the maximum number of frames shown is 4 (which is genrally linear animation mode). This is just an animation error according to me. If you animate it in triansient mode instead of linear mode your problem may get solved.

Share this post


Link to post
Share on other sites
Guest

Hi @Karthic

 

 

One more issue is that the green component is set with rigid and when the stiffness is set AUTO contact stiffness is calculated at a different stiffness.

 

Try to remove rigid and apply load on nodes of Green component and please check the results. 

 

 

Share this post


Link to post
Share on other sites

Hi @Prakash Pagadala,

I have tried removing the rigid and  load on nodes of Green component, but no improvements in the contact penetration.

I also tried making  contact stiffness to SOFT. The same  penetrating behavior was observed...

 

Share this post


Link to post
Share on other sites

@Prakash Pagadala,

Thank you,

Either I should make it rigid or solid part. It cant be shell part.

 

what if I make the part as solid and still gets penetration....

Is it ok, can I have these penetrations

Or any other way to avoid the penetration, the model being solid or rigid

 

Share this post


Link to post
Share on other sites
Guest

Hi @Karthic

 

I wrote to experts and waiting for their reply.

 

Usually, the penetration could be because of contact stiffness. 

 

Have you tried with PCONT?

Share this post


Link to post
Share on other sites

@Prakash Pagadala

Ya

On Saturday, April 21, 2018 at 8:21 AM, Karthic said:

Hi,

As shown in GIF, facing penetration issue for surf to surf continuous sliding contact.

1. Tried changing the master and slave

2. Tried S to S and node to surface

3. Used Pcont,  tried stiffness value (1000 & 100000) , auto, soft & hard

4. Also tried changing material

5. Tried with Opengap, Norm

But still I couldn't correct the penetration issue

 

The fem file is attached to this. Please do help me with the issue.

Share this post


Link to post
Share on other sites
Guest

Hi @Karthic

 

Can you try with NLGEOM and PCONTX7 where you can more control over contact stiffness (Istiff)?

 

Since contact stiffness is based on the stiffness of the components, you can also try to reduce the thickness and check if that helps. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...