Jump to content
baozaizhang

Problem in using solid map

Recommended Posts

In Fig. 1, it is a screenshot of a 3D solid that I plan to mesh, I have a very thin slice at the top (please see circled region in Fig. 2). 

 

1. I meshed the top surface as shown in Fig. 3.

2. I plan to use solidmap to mesh the top slice first, and then mesh the rest of the 3D solid. I select all the surface elements as my source elements, I select the bottom of the top slice as my destination surface. I select one side surface as my "along geom" (as shown in Fig. 4)
3. After I click mesh, an error message shows up "Term-face-edge has a srong side-face edge idx" and several faces become white as shown in Fig. 5.

 

Would you please tell me what is the reason for this? By the way, I first have a rectangular cross section and then I cut the four corners to make it like this.

 

Thank you very much for your help.

 

image.png.5fd5ebef62fef8c602e40e71d02ca236.png

Fig. 1

 

image.png.4b02c3790b518c924dec8419decb7158.png

Fig. 2

 

image.png.f9681edf6c7cb1174e44f466ddc439ba.png

Fig. 3

 

Fig. 4

 

image.thumb.png.22d3e91953138de08d13b429c04fd8c2.png

Fig. 5

image.png

image.png

Share this post


Link to post
Share on other sites
13 hours ago, tinh said:

Hi 

try selecting all slant surfs as "along"

Hello, Tinh,

 

Thank you for your suggestions. I tried to select all the side surfaces as the "along", but I got the following error:

image.png.d614c77ceefb1c3d7cdf2427bbb5000f.png

 

The model looks like the following Fig.1. And at the four chopped corners, I have three surfaces there rather than one (Pls see Fig. 2). may I ask if you got any comments on this?

Thank you.

image.png.b3a1dd9c7895f1fbd88711d6d59b170c.png

Fig. 1

 

image.thumb.png.2194db1e4100250c147ae6e6938e4f41.png

Fig. 2

Share this post


Link to post
Share on other sites

Another interesting thing is if I jus

10 minutes ago, baozaizhang said:

Hello, Tinh,

 

Thank you for your suggestions. I tried to select all the side surfaces as the "along", but I got the following error:

image.png.d614c77ceefb1c3d7cdf2427bbb5000f.png

 

The model looks like the following Fig.1. And at the four chopped corners, I have three surfaces there rather than one (Pls see Fig. 2). may I ask if you got any comments on this?

Thank you.

image.png.b3a1dd9c7895f1fbd88711d6d59b170c.png

Fig. 1

 

image.thumb.png.2194db1e4100250c147ae6e6938e4f41.png

Fig. 2

Another interesting thing is if I just use the setup I showed above for the "solid map", I set 2 elements in the height direction, but I finally get the following: 

The elements near this region only have half of the height mapped while other parts are mapped from the source to destination with all height, but just 1 element rather than 2 as I wanted.

image.thumb.png.1bb652692ca995c60ac48479d5b47a69.png

 

If I select a different chopped region to do the solid map, I got the error saying "Side face 1: not enough connections to dest face loop".

Does this mean there is some strange part in my geometry?

 

Thank you very much for your help.

 

image.thumb.png.7d475c8dcf1d7ea429458c2e74bff23b.png

 

image.png.b7ff6e52eb883abdda9ab1754c291466.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...