Jump to content
Jim.Ryan

Compiler required to use Modelica with Activate

Recommended Posts

When I tried to run one of the tutorials associated with the Modelica set that comes with Activate , I received an error message shown in the attached screenshot file.  That message indicates "Modelica compiler requires Visual C++ compiler version >= 10".  If I download and install the "Microsoft Visual C++ 2015 Redistributable Update 3 RC", do you expect that will resolve this error?

 

simluation_error_message.JPG

Share this post


Link to post
Share on other sites

Hi Jim,

 

I had the same issue. I think the redistributables are not enough, because they only contain run-time libraries for c++, but no compiler. After installing a full VC++ compiler (e. g. Visual Studio 2015 from here or here [you have to choose "older versions" at bottom of the page]) Modelica models work fine. With VS 2017 I didn't get it running.

 

Ronald

Share this post


Link to post
Share on other sites
On 4/30/2018 at 9:44 PM, Ronald Kett said:

Hi Jim,

 

I had the same issue. I think the redistributables are not enough, because they only contain run-time libraries for c++, but no compiler. After installing a full VC++ compiler (e. g. Visual Studio 2015 from here or here [you have to choose "older versions" at bottom of the page]) Modelica models work fine. With VS 2017 I didn't get it running.

 

Ronald

 

Hi Ronald,

 

After installing a full VC++ compiler (vs 2015 community) the error message still exist. 

I use this command "vssGetCompilerName()" to check compiler, and it shows that there doesn't exist any compiler on my computer.

It seems to Activate does not detect compiler automatically. But I'm sure that vs 2015 community is installed on my computer.

Do you have any idea to fix this problem? Thank you.

 

Willy

Share this post


Link to post
Share on other sites

Hi Willy,

 

You have to set the compiler in Preferences (Menue File-Preferences):

 

image.png.750e8f09d51deb80a33de6ad9eecee60.png

 

After adding the compiler you should get Modelica models running.

 

Best Regards,
Ronald

Share this post


Link to post
Share on other sites

Hi Ronald,

 

Thank you for your reply, 

I follow your suggestion to set the path in Preferences:

 

02.thumb.JPG.0e67a02f8ec94fb075ce9b5645b8ed46.JPG

 

When I tried to run Modelica models, the error message still pop up:

 

00.JPG.66d9f97186ddf8a51ba841a93aa34dfa.JPG

 

Otherwise, If I unselect the "Modelica Engine powered by Maplesoft" option, another error message will shown as:

 

01.JPG.130fe85058e915bb5eb9cbb01ac2e65b.JPG

 

It's really weird, did I miss any settings during installation of Activate or VC++?

 

Best regards,

Willy

Share this post


Link to post
Share on other sites

Hi Willy,

 

In the meantime I got to know that the compiler setting in preferences belongs to the Modelica compiler, not to the C/C++ compiler. Therefore the field can be left empty (in my installation).

 

Please check if you have installed C/C++ option and SDK option during installation process of VS. This is the important compiler of the package.

 

Regards,
Ronald

Share this post


Link to post
Share on other sites

Yes, I have the same issue of this.

And I click on the SDK option. then I solve this issue.

Hope it can help you.

 

I install 2019, you need make some choice when you starts to install.

Share this post


Link to post
Share on other sites

I have Altair Activate Basic 2019 and I have the same issue. On top of that, I do not see the select Compiler option with my version as shown in the screenshot. Could anyone suggest a workaround? I have installed VS 2019 with the SDK option also installed.

 

Thanks,

Rajath

compiler_issue.PNG

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...