Jump to content
Sign in to follow this  
Daniel

plot appears okay, but playback skips data points

Recommended Posts

-I have a plot in hyper graph that I'm attempting to sync it with a video, however, when i play the file from Hyperview the cursor appears to jump along data points, instead of quickly going through all data points and appearing smooth. 


 


-Its not an issue with playback speed, nor the time increment. If I adjust the increment to a small value, and click the 'skip forward' button, (not the one that jumps to the end, but the button immediately to the right of the play button), it simply takes more clicks for the cursor to jump, and it still jumps by the same amount. 


 


-When I try any tutorial or demo file the playback goes through all coordinates. 


 


-I will also add that my file is relatively huge, data was taken every 2 milliseconds, and the file is about an hour and 15 minutes of data, so there are over a million data points. Does this large file size have to do with anything?


 


-Even when I try to trim my clip down to about 10 seconds worth of data (still 5000 coordinates) it still jumps in these mysterious increments.


 


-My data is coming from a csv file.


 


-Forget about the fact that I'm syncing it to video, because even when I start over with only one plot on the page, I get the same issue.


Share this post


Link to post
Share on other sites

-It appears that my data plays back in what it thinks are frames. It turns out that it thinks a frame is about 1.6 seconds of my data. This is playing roughly every 800th point or so of data. (500 data points per second).


 


Question: is there any way to make the animation playback NOT go by frames when it's under the impression that the data includes frames (but it doesn't)?


 


 


 


Also, I trimmed the data down and tried to attach it, but it says I'm not permitted to post that type of file..


Share this post


Link to post
Share on other sites
Guest

Hello,


 


you can change from frames to time at animation control.


Maybe you have a hyperview task in a window (animation), then you have to synchronize the animations.


Use the button "Time scale" at animation control and change your master to the plot window...


 


Regards,


Mario

Share this post


Link to post
Share on other sites

We finally figured out that the software isn't capable of playing back our large amount of data. We calculate the maximum number of lines of data to be played individually to be roughly 1278 points or frames. So if your data has any more than this amount, it will just linearly interpolate the points during playback and divide your data up into about 1278 frames and the cursor will jump at whatever interval is about 1/1278th of your entire data set. For example, if your data has double this amount of XY coordinates (~2556), when you click play and zoom in close, during playback the cursor will jump to every other data point.


 


We are searching for other options at this time.


 


Thanks Mario for the reply though!


Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...