Jump to content
MOHAMED HAMDALLA

Control modes sorting in CMA

Recommended Posts

Hi all,

is there any way to sort the modes for characteristic mode analysis in PostFeko. That is mode 1 is the actual mode 1 and mode 2 is the actual mode 2 and so on. Because sometimes I cheek the modal significance to find some of them is a point of two points.

Thanks

Share this post


Link to post
Share on other sites

Thanks for the question @MOHAMED HAMDALLA.

 

Could you please clarify with a bit more detail or screenshots. It sounds like your question might relate to mode tracking. Note that we are constantly improving the algorithm and would therefore suggest that you use the latest version of FEKO. Also note that mode tracking tends to be more sensitive to meshing and frequency resolution.

 

You may also want to read this post in the forum.

Share this post


Link to post
Share on other sites

To answer the first part of your question:
Characteristic modes are numbered at the lowest frequency, with mode 1 being the most the significant at that frequency. Some modes that are used by the tracking algorithm are also assigned numbers at this frequency, and as modes fall into and out of the modal significant range (determined by the number of modes requested) new mode numbers are assigned dynamically. The user can give no input on the numbering.

 

As Peter said, a screenshot of the modal plots you are having problems with would help to answer your question fully.

Share this post


Link to post
Share on other sites

image.png.f9e0de926a8be49904dd9f144be6e573.png

Thanks a lot for replying.

My concern is the following: in the attached figure, file.out will not arrange the modes according to their numbers all the time. At Some frequencies, the order will be changed to be mode 2 mode 3 mode 1 and at another frequency, it will be mode 3 mode 1 mode 2. Also, when I request 2 modes only I got 4 modes sometimes and if I request 6 modes it will give me more than 100 in some cases. I know that's because of the tracking algorithm " which is great and thanks a lot for your efforts" but till now there is no way to solve this issue?

Thanks

Share this post


Link to post
Share on other sites

What is happening here is that the modes are assigned numbers so that we can consistently refer to a single mode across frequencies.

At every frequency the *.out file will list the modes of that frequency in order of Modal Significance. The mode tracking algorithm will however determine mode numbering. In your example of getting modes in order 3-2-1, that simply means that at this frequency mode 3 is the most significant followed by mode 2 then lastly mode 1.

 

When you request 6 modes you will only receive results for 6 modes at every frequency, but you will receive the most significant 6 modes at that frequency. This means that over the requested frequency range some modes will fall out of significance and new modes will enter significance. It is then very possible for a mode with the number 'mode 100' to be in the top 6 most significant modes at a later frequency.

 

If you would like the modes numbered 1 to 6 at every frequency you can disable tracking in the *.pre file. The easiest way is to use EDITFEKO. The CMA request will look something like this:
 

** Characteristic modes
OM: 6 : 1 : -1   ** CharacteristicModes1

With the last number indicating that tracking is disabled.

MOHAMED HAMDALLA likes this

Share this post


Link to post
Share on other sites

You will always get the most significant modes at every frequency, so the result set is the same with or without tracking.

If tracking is disabled those modes will just be numbered 1 to 6 at every frequency.


To make untracked plots easier to interpret I usually set all line colours to black.

Share this post


Link to post
Share on other sites

sir,i'm chinese users,for some unkown reasons, i  can't download the CMA plotter  ,could send me  one  to 497408506@qq.com ,thx! it's very urgent to me

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...