Jump to content

Recommended Posts

Hiw can we add buffet space region in fem modeling. It shows this error that I need to define some boundary region with some dielectric material.

Share this post


Link to post
Share on other sites

Hi Kartik

 

Can you share your model or the exact error message?

 

If I have to guess, I'd say you might be trying to solve a problem where the MoM and FEM regions are decoupled. There should be an outer region to the problem that has the medium properties of "Free space".  You can refer to the FEKO Examples Guide for examples on how to set up FEM models.

 

Kind regards
Madelé

Share this post


Link to post
Share on other sites

Hi Kartik,

 

4 minutes ago, M van der Merwe said:

Can you share your model or the exact error message? 

I agree, you are not giving us much to work with. ;-) Please add more details or the model.

 

Besides the guesses ventured by @M van der Merwe, it could be that you are using lossy metals on a FEM/MoM boundary and this is not supported. Adding a FEM region in this area or around your model should resolve the problem. How to do this? It really just means that you need to create a region around your model (and obviously union the region with the model) and then set the region to be solved with FEM and use the properties of free space.

Share this post


Link to post
Share on other sites

Hi Kartik

 

Thanks for posting more details. Anisotropic media are not supported on the boundary of a FEM region. You need to place an airbox (FEM region with the properties of free space) around this region or around your model.

 

Quote

Adding a FEM region in this area or around your model should resolve the problem. How to do this? It really just means that you need to create a region around your model (and obviously union the region with the model) and then set the region to be solved with FEM and use the properties of free space. 

1

 

Share this post


Link to post
Share on other sites
1 hour ago, MvdM said:

Hi Kartik

 

Thanks for posting more details. Anisotropic media are not supported on the boundary of a FEM region. You need to place an airbox (FEM region with the properties of free space) around this region or around your model.

 

 

Thank you for replying

 

I tried what you suggested and now it shows the error that two tetrahedral regions are overlapping. I have ensured that all the faces or regions are not touching each other but the error still exists. Is there any way to know that which surfaces or areas are giving this error? How do I fix it?

Share this post


Link to post
Share on other sites

Looking at the image you shared above, it seems that you are using FEKO 2017.2. You could try switching between the two mesh engines in that version and see if that resolves the problem. On the ribbon, use the Meshing group dialog launcher and check/uncheck "Use legacy mesher". Select OK and mesh your model again.

image.png.04f5188e11b7cb8af75396a27cf8f985.png
 

If this doesn't help, could you share the model (or a simplified example model) that shows this behaviour?

There are many mesh improvements in FEKO 2018 that might result in an improved mesh.

Share this post


Link to post
Share on other sites

Hi Kartik

 

I had a quick look at your model. Adding airboxes should resolve these errors.

 

You have both FEM and MoM regions in the model.

  • The horn is excited by a FEM modal port, the waveguide part is set to FEM and meshed into FEM tetrahedra.
  • No solution is set on the horn flare, so this is solved by the default MoM solver (surface mesh).

The MoM region on the inside of the chamber connects directly to the absorber FEM regions of the absorbers and lacks an airbox.

 

There are also metallic (Iron) faces on the boundary of a FEM region. This is not allowed on the boundary (the outside of) a FEM region. These faces can be modelled when inside a FEM region (could be air).

 

Here is an example of an airbox from the FEKO Example Guide (example A12, DRA_Finite_Modal.cfx):

exa12_airbox.png.e312d029e521c8c697622a1c9c44ebdb.png


The pink shows a layer of air (free space) that is added around the dark blue FEM region (not free space). A union is created to ensure connectivity and correct meshing of these layers.

 

 

Kartik likes this

Share this post


Link to post
Share on other sites

Thanks,

I have tried what you suggested but there is an error showing that a modal port must contain dielectric areas. I have tried all the options according to my understanding. Can you please help me with this?

The model is attached here.

 

Anechoic_2.cfx

Share this post


Link to post
Share on other sites

Hi Kartik,

 

FEM modal ports must be assigned to dielectric boundary faces, contrary to MoM waveguide ports, which are assigned to PEC faces.

 

image.thumb.png.1d14a59aee17e71abc0434e45c4f8782.png

Also, there is a PEC face blocking the wave transmission:

image.png.1fb3ede68821a3068f247596dee8b815.png

Setting also this face to dielectric boundary should help.

Furthermore, the top part of the horn is isolator, shouldn't it be Air instead?

image.png.66cacbebfe20b25e40257128fc54c275.png

Last but not least, FEM modal ports between two dielectric regions are not supported (that's what the warning is referring to). I would rather cut the outer air box like this:

image.png.e27b23597764011603b3e71e71eff2e3.png

The model is attached: Anechoic_2-1_alt.cfx

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...