Jump to content
Dzh_lin

Tetramesh problem in hypermesh 2017

Recommended Posts

Hi guys,

     I find there is some bug in tatramesh with hm 2017 while it is ok in hm14.0.

     For the same solid, after I split it with same params, and then mesh the solid body, the number of node and elements are different each time in hypermesh 2017.2;

     But in hm 14, It OK

     The steps I do as follow:

     1\open hypermesh

     2\import utg model (attachment)

     3\split the solid with X-plane-(0 0 0)

     4\mesh the solids 

     5\remember the number of the node and elements

     6\repeat 1-5 and compare with the first number.

 

How to fix this problem ?

Thanks .

solidTest_ug.prt

Share this post


Link to post
Share on other sites
7 minutes ago, Premanand Suryavanshi said:

Hi  Dzh_lin,

 

After trimming the solid, Mask half of the solid and mesh it. Then, Reflect the elements to other half.

 

 

Thank you

 

Hi Premanand Suryavanshi,

  Thanks,

  I used this function with tcl code, and the model always can not mesh by reflect.

  I think it may be a bug ? or there is some other setting ?

Share this post


Link to post
Share on other sites
7 minutes ago, Premanand Suryavanshi said:

I think the program might be written in that way . I don't see any other settings to fix this.

 

Thank you

Yes,Maybe。

But the same issue do not appear in hypermesh 14.0.

So this problem confused me.

I think those change for some geometry do not have advantage for analysis.

Share this post


Link to post
Share on other sites
On 7/10/2018 at 1:14 PM, Dzh_lin said:

Hi tinh,

   Thanks .

    It does affect the result.

:unsure:

 

You can mesh it once, save it as an hm file.

with each analysis, you import the hm file to set up parameters...

so analysis will not be affected by different node count/ elem count

Share this post


Link to post
Share on other sites
2 minutes ago, tinh said:

 

You can mesh it once, save it as an hm file.

with each analysis, you import the hm file to set up parameters...

so analysis will not be affected by different node count/ elem count

Thanks tinh,

this maybe one way.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...